I just downloaded and installed Ubuntu 16.04.3 for my Sony Vaio Z Series laptop.

After the installation finished, a message asked me to restart. When I clicked on it, it just froze, so I shut down the laptop directly using the shutdown key.

Once I rebooted the laptop, I can log in a as guest without any problem (although it freezes when changing language or logout).

But I can't open my user account; I enter the password, click log in, then it freezes, although I still can move the cursor.

I executed apt-get install unity and dpkg-reconfigure, I've also tried apt-get remove --purge nvidia*.

I have the same problem with Ubuntu 17.04. I installed 16.04 and 17.04 twice, but still can't fix this issue.

I've also tried apt-get dist-upgrade, but it didn't help.

After setting the kernel boot parameters to quiet splash nomodeset, I can log in, but the problem is that with nomodeset the resolution is annoying.

How can I fix this problem?

  • 1
    Did you install a video driver? If you boot to a Ubuntu Live DVD/USB, does it also freeze in the same way? Also, check the Sony web site to see if there's a BIOS update available. – heynnema Aug 6 '17 at 18:01
  • Thanks for your reply, I tried to install nvidia drivers, but it's just messed up now. I now can log in with the nomodeset disabled, but now it freezes on shutdown, so again I use the shutdown key to restart... and when I do, it switches back to nomodeset. – SmootQ Aug 6 '17 at 18:58
  • 1
    Please clarify. Is "quiet splash nomodeset" still set? Where did you get the Nvidia drivers from... their web site, or the Ubuntu repos? The shutdown freeze may be a different problem. Did you check the BIOS? Does the Live DVD work properly? – heynnema Aug 6 '17 at 19:01
  • I did sudo apt-get install nvidia-370 in the ppa:graphics-drivers repository. How to check the BIOS? , for the installation I created a Live USB after I downloded ubuntu from the website. – SmootQ Aug 6 '17 at 19:12
  • 1
    Did you edit /etc/default/grub and then sudo update-grub? To check the BIOS, enter the BIOS at power on time, note the current version #, go to the Sony web site... support/downloads... enter your model #, look for BIOS updates, compare to your version. – heynnema Aug 6 '17 at 19:21

I fixed the problem. Here's what I did exactly:

Since this happened after installing Ubuntu 16.04, and because nvidia drivers got messed up (as I was trying to solve the problem), I decided to reinstall Ubuntu again and try another solution.

  1. I installed Ubuntu
  2. With my new clean installation, I opened the GRUB menu by pressing the right shift key on reboot.
  3. In the GRUB menu, I browsed with arrow keys to Ubuntu, press e to edit the boot parameters.
  4. I browsed to the line starting with linux, and added nomodeset after quiet splash. Then pressed F10 to boot.
  5. Now I could log in using my user account, I entered the password and got access to my desktop.
  6. I searched for System Settings in the launcher, then Software & Updates, I set download from to Main Server. Then opened Additional Drivers tab, and checked one of the Nvidia (Proprietary, tested) drivers.
  7. It took a very long time for Applying changes to finish (about an hour), and once it finished, I rebooted as normal (without nomodeset), and this time I could access to my user account.

Hope this helps others.


I had the same problem. The following commands worked for me:

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity

Hopefully it will work on your computer too.

  • Thank you so much, +1 , check my answer to see how I fixed my problem, because reinstalling ubuntu-desktop and installing unity didn't work for me. – SmootQ Dec 27 '17 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.