0

I found rather informative thread regarding turbo-boost here: Disabling Intel Turbo Boost in ubuntu

I followed all the recommendations, but can't get it disabled.

I am running HP Pavilion 17-e182sr with Intel i7-3632QM (2.2 - 3.2 GHz). Its default frequency is 2.2GHz which seems to work fine for me. Since it is a laptop I don't want to overheat it. My temperatures are up to 85°C with the full load. So disabling turbo boost seems the most suitable solution.

It was super easy to disable turbo boost in Windows environment, but Linux appears to be much tricky. I've already created a script to disable turbo boost as advised by @Maythux. For the matter of facts, here are my outputs.

~$ cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver
intel_pstate
intel_pstate
intel_pstate
intel_pstate
intel_pstate
intel_pstate
intel_pstate
intel_pstate

$ lscpu | grep MHz
CPU MHz: 1200.036
CPU max MHz: 3200,0000
CPU min MHz: 1200,0000

~$ cat /sys/devices/system/cpu/intel_pstate/no_turbo
1
~$ sudo rdmsr -p0 0x1a0 -f 38:38
1
~$ sudo rdmsr -p1 0x1a0 -f 38:38
1
~$ sudo rdmsr -p2 0x1a0 -f 38:38
1
~$ sudo rdmsr -p3 0x1a0 -f 38:38
1
~$ sudo rdmsr -p4 0x1a0 -f 38:38
1
~$ sudo rdmsr -p5 0x1a0 -f 38:38
1
~$ sudo rdmsr -p6 0x1a0 -f 38:38
1
~$ sudo rdmsr -p7 0x1a0 -f 38:38
1

SEEMS PRETTY COOL, HA? But the current CPU frequencies are

~$ cat /proc/cpuinfo | grep "MHz"
cpu MHz : 2902.539
cpu MHz : 2899.987
cpu MHz : 2908.984
cpu MHz : 2900.256
cpu MHz : 2902.136
cpu MHz : 2902.807
cpu MHz : 2962.023
cpu MHz : 2899.987

Can somebody shed some light on what am I doing wrong? Thanks for all the comments here.

  • 1
    /proc/cpuinfo can be wrong. Use i7z instead of investigating your CPU frequencies. Also have a look at cpufreq-info and the governor set. All in all, I would not disable TurboBoost. You CPU is OK up to 105°C according to ark.intel.com. – Thomas Aug 6 '17 at 11:30
  • Thank you for the reply. I did install i7z, but it shows the same stats for my CPU frequencies. Cpu speed from cpuinfo 2194.00Mhz Real Current Frequency 3055.05 MHz [99.73 x 30.63] (Max of below) Core [core-id] :Actual Freq (Mult.) C0% Halt(C1)% C3 % C6 % Core 1 [0]: 3055.05 (30.63x) 98 0 0 0 Core 2 [2]: 2943.94 (29.52x) 9.68 3.15 2.98 0 Core 3 [4]: 2943.26 (29.51x) 8.59 10.3 1.79 0 Core 4 [6]: 2963.46 (29.72x) 14.1 3.01 5.37 0 – Dmitriy Morozov Aug 16 '17 at 8:49
  • The current governor is powersave which I assume should use lower frequencies: $ cpufreq-info | grep governor available cpufreq governors: performance, powersave The governor "powersave" may decide which speed to use – Dmitriy Morozov Aug 16 '17 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.