When I run apt-get update, I get this error message:

Err:18 http://dl.google.com/linux/chrome/deb stable Release.gpg                
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6494C6D6997C215E

I understand what causes this issue. I wonder how to fix it.


I tried the most upvoted solution provided in the duplicate link:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 6494C6D6997C215E

I got this new issue which does not seem to be resolved on this website according to the posts I saw:

Executing: /tmp/tmp.jyolnTyZuJ/gpg.1.sh --keyserver
gpg: requesting key 997C215E from hkp server keyserver.ubuntu.com
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error
  • 1
    It works for me. You have some internet connection problem.
    – Pilot6
    Aug 6, 2017 at 10:59
  • @Fabby: To me it reads almost exactly the same as the first alternative of karthick87’s. Dec 23, 2018 at 8:18
  • @DavidFoerster Bowing to the master! :-) Urgh... Cannot retract reopen vote! ;-(
    – Fabby
    Dec 23, 2018 at 20:57
  • That error can also be caused by putting an ASCII-Armored file in /usr/share/keyrings, if you are doing that to avoid using apt-key add as recommended here: wiki.debian.org/DebianRepository/UseThirdParty
    – BCS
    Apr 15, 2020 at 19:46

1 Answer 1


I want to share what I found here (running over port 80):

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 6494C6D6997C215E

And that was successful:

Executing: /tmp/tmp.BX24beQ8ze/gpg.1.sh --keyserver
gpg: requesting key 997C215E from hkp server keyserver.ubuntu.com
gpg: key D38B4796: "Google Inc. (Linux Packages Signing Authority) <[email protected]>" 3 new signatures
gpg: key D38B4796: "Google Inc. (Linux Packages Signing Authority) <[email protected]>" 1 new subkey
gpg: Total number processed: 1
gpg:            new subkeys: 1
gpg:         new signatures: 3

I then run sudo apt-get update and everything went fine.

  • 2
    It looks like your default settings are non-standard. It works for me without specification of a port.
    – Pilot6
    Aug 6, 2017 at 11:08
  • 2
    @Pilot6 or they're behind a firewall of some sort, so port 11371 is blocked.
    – muru
    Aug 8, 2017 at 0:44
  • It works for me without the scheme and port.
    – Vunb
    Apr 6, 2018 at 2:34
  • This post linuxconfig.org/… helped me before I could find this one.
    – Arvind K.
    Sep 25, 2020 at 12:20
  • Doesn't want to import that key it says it already exists.
    – Sephethus
    Nov 5, 2022 at 17:04

Not the answer you're looking for? Browse other questions tagged .