29

This question already has an answer here:

When I run apt-get update, I get this error message:

Err:18 http://dl.google.com/linux/chrome/deb stable Release.gpg                
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6494C6D6997C215E

I understand what causes this issue. I wonder how to fix it.

EDIT:

I tried the most upvoted solution provided in the duplicate link:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 6494C6D6997C215E

I got this new issue which does not seem to be resolved on this website according to the posts I saw:

Executing: /tmp/tmp.jyolnTyZuJ/gpg.1.sh --keyserver
keyserver.ubuntu.com
--recv-keys
6494C6D6997C215E
gpg: requesting key 997C215E from hkp server keyserver.ubuntu.com
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

marked as duplicate by Pilot6, karel, Eric Carvalho, WinEunuuchs2Unix, Kevin Bowen Aug 8 '17 at 20:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    It works for me. You have some internet connection problem. – Pilot6 Aug 6 '17 at 10:59
  • @Fabby: To me it reads almost exactly the same as the first alternative of karthick87’s. – David Foerster Dec 23 '18 at 8:18
  • @DavidFoerster Bowing to the master! :-) Urgh... Cannot retract reopen vote! ;-( – Fabby Dec 23 '18 at 20:57
38

I want to share what I found here (running over port 80):

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 6494C6D6997C215E

And that was successful:

Executing: /tmp/tmp.BX24beQ8ze/gpg.1.sh --keyserver
hkp://keyserver.ubuntu.com:80
--recv-keys
6494C6D6997C215E
gpg: requesting key 997C215E from hkp server keyserver.ubuntu.com
gpg: key D38B4796: "Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>" 3 new signatures
gpg: key D38B4796: "Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>" 1 new subkey
gpg: Total number processed: 1
gpg:            new subkeys: 1
gpg:         new signatures: 3

I then run sudo apt-get update and everything went fine.

  • 2
    It looks like your default settings are non-standard. It works for me without specification of a port. – Pilot6 Aug 6 '17 at 11:08
  • 1
    @Pilot6 or they're behind a firewall of some sort, so port 11371 is blocked. – muru Aug 8 '17 at 0:44
  • It works for me without the scheme and port. – Vunb Apr 6 '18 at 2:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.