I'm not sure when this happened or why, but pacmd list-cards shows 0 card(s) available..

Now my audio doens't work, and all I see in the Sounds application is "dummy output".

How can I re-add the sound card? I should note that I wasn't messing with this. One day it just randomly stopped working.

This is what I see from aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0   

I have tried googling for this and tried various fixes such as sudo apt-get dist-upgrade and re-installing the audio stuff. Nothing has worked so far.


Solved it by first running:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get autoremove

then running:

sudo killall pulseaudio
rm -rf ~/.config/pulse
pulseaudio -k

This restarts pulse and re-builds the config files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.