1

I have an "okay" classic-style (no lens, etc) desktop running on an Ubuntu 16.04 server. gnome and ubuntu-desktop is installed, and I have several desktops available, such as ubuntu.desktop, gnome.desktop, and gnome-classic.desktop.

I would like to run the new gnome that I have on my local desktop, which is Gnome 3 (also perhaps it is called Gnome with the Awesome Desktop).

How can I do that? Below is the xstartup file that I have now:

#!/bin/sh

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
x-window-manager &

#export XKL_XMODMAP_DISABLE=1
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS

gnome-session --session=awesome --disable-acceleration-check &
gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &

pulseaudio -k
pulseaudio -D

I've tried all the info at: How to change to other desktop environment on VNC sessions?

1

Your script is wrong!

First, you possibly try to start 3 different window managers:
- x-window-manager will start default window manager or your pc.
- gnome-session will start window manager that is used in Awesome desktop.
- metacity you try to explicitly start window manager.

If you want to start full session using gnome-session then you should remove x-terminal-emulator, x-window-manager, gnome-panel, gnome-settings-daemon, metacity and nautilus.

If you really want that there is opened terminal and/or file manager window automatically when you start it then you can leave x-terminal-emulator and/or nautilus, but other things should be removed.

gnome-session will start everything you need, but if that will work depends on your desktop. If it requires hardware acceleration then it will not work.

--disable-acceleration-check is used to disable this check, but it won't help if acceleration is hard dependency for your desktop.

3
  • Thanks, that makes a lot of sense. I want to go in the direction of gnome-session only. This is on an ec2 medium.t2 instance, and in the past, these ec2 instances did not have hardware acceleration: One could not run Ubuntu Unity desktop on them because of that, for example. How can a hard dependency on hardware acceleration be checked for? If a hard dependency is found, what are places to look for alternatives? Ideally, I would like to run the Gnome3 Awesome desktop, but I see that, while awesome.desktop is listed on my system, it is not directly a gnome desktop. – christopherbalz Aug 6 '17 at 22:56
  • Remove --disable-acceleration-check and add --debug. Then gnome-session will do needed things. If session does not start then check ~/.xsession-errors – muktupavels Aug 7 '17 at 4:43
  • Hello, we removed all the items you mentioned and kept x-window-manager. When we tried with "gnome-session --debug", the screen showed solid gray but with no errors in xsession-errors file. However in syslog file we see : "gnome-session-binary[1502]: WARNING: software acceleration check failed: Child process exited with code 1. " So we further added "--disable-acceleration-check". With this we see only the wallpaper and nothing more. Then we added "gnome-panel &" and that helped us to get the menu bars showing. The theme of the menu is dark but we do not have a fully fledged Gnome3 UI. – ZakiMak Aug 12 '17 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.