0

I've installed Ubuntu 16.04 to replace 14.04 and most of my devices were discovered and re-installed on a finger click. Yet I have no cue how quite archaic but still operational printer Epson EPL-6200L can be re-installed. So far whatever I tried to do this piece of equipment just refuses printing test page even the task is sent to printer with no problem (as per printers monitor). Any suggestions anybody? Your feedbacks are much appreciated.

0

Here is how it worked out for me:

Download "epsonepl" driver from here, at the moment Version 0.4.1 is actual

Let's assume you have all your downloads in 'downloads' folder

Install ubuntu package build-essential

Install below commands as root, EPL-6200L is taken as example, corresponding changes should give you a solution for other Epson EPL-5xxxL and 6xxxL models:

$ sudo tar zxvf  /downloads/epsoneplijs-0.4.1.tgz
$ cd epsoneplijs-0.4.1/
$ sudo ./configure
$ sudo make
$ sudo make install
$ sudo mkdir -p /usr/share/cups/model/foomatic-ppds/Epson/
$ sudo mkdir -p /usr/share/foomatic/db/source/driver/
$ sudo mkdir -p /usr/share/foomatic/db/source/opt/
$ sudo mkdir -p /usr/share/foomatic/db/source/printer/
$ sudo cp -av {*full path to folder on your machine*}/foomatic_PPDs/Epson-EPL-6200L-epl6200l-cups.ppd.gz /usr/share/cups/model/foomatic-ppds/Epson/
$ sudo cp foomatic/driver/epl6200l.xml /usr/share/foomatic/db/source/driver/
$ sudo cp foomatic/opt/epsonepl-* /usr/share/foomatic/db/source/opt/
$ sudo cp foomatic/printer/Epson-EPL-6200L.xml /usr/share/foomatic/db/source/printer/
$ sudo ln /usr/local/bin/ijs_server_epsonepl  /usr/bin/
$ sudo cp /usr/share/cups/model/foomatic-ppds/Epson/Epson-EPL-6200L-epl6200l-cups.ppd.gz /etc/cups/ppd/EPSON-EPL-6200L.ppd.gz
$ sudo gunzip /etc/cups/ppd/EPSON-EPL-6200L.ppd.gz
$ sudo /etc/init.d/cups restart

Then create a new printer named "EPSON-EPL-6200L" via the cups web interface on http://localhost:631

Should be done. Now your old-fashion printer should work as you expect. In case it still does not, download from direct link PDD file from here, and via 'Printers' system setup choose this file as driver. Please notice that some Ubuntu versions don't have test print page template for old-fashioned printers at all. So try to print any text document instead. The above has been successfully tested on 18.04 as well

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.