0

I am new to Linux, and I need to install SUPREMIII on Ubuntu 16.04. I have already downloaded the .tar.gz package and extracted it. I have followed the instructions given in the README file downloaded from SUPREM3 RELEASE B.8628 http://www-tcad.stanford.edu/tcad/programs/oldftpable.html, but I was unable to install it because of the errors shown in the below screenshot.

enter image description here

I have installed the GNU Fortran compiler using sudo apt install gfortran so I'm able to resolve the error f77: Command not found but a new error has popped up (see below).

enter image description here

I'm able to run the Makefile for genii, but when I use the make command for setup, it results in the following error:

anala@anala-Lenovo-G580:~/Desktop/Release/src/setup$ make  
loading...  
setup.o: In function MAIN__':  
setup.f:(.text+0x1c6): undefined reference to fdate_'  
opnfl-L.o: In function opnfl_':   
opnfl-L.f:(.text+0x77): undefined reference to geten_' 
collect2: error: ld returned 1 exit status 
Makefile:34: recipe for target '../../run/setup' failed   
make: *** [../../run/setup] Error 1
  • There is a make replacement package named cook in the default Ubuntu repositories that contains the missing f77 executable in the f77: Command not found error message. To install it from the terminal type: sudo apt install cook. I don't believe that your problems will be over yet unless you also install the plotcap libraries listed in the README file that you downloaded. – karel Aug 5 '17 at 7:52
  • i did install the cook package but still unable to install the software..may i know from where and how to install the plotcap libraries.. – anala Aug 6 '17 at 15:24
  • Welcome to Ask Ubuntu. Suprem-III is an old Fortran program. I searched for the plotcap libraries for Linux for a while, but I couldn't find all of them. – karel Aug 6 '17 at 19:51
  • I have downloaded the Plotcap Release 9016 tarball that's listed under Support Programs on the Stanford TCAD webpage :www-tcad.stanford.edu/tcad/programs/oldftpable.html. It would be of great help if u could tell me the procedure on how to build them. – anala Aug 7 '17 at 5:41
  • I download the same file. There's no README in the archive, however the usual way to compile a .tar.gz file is How do I install a .tar.gz (or .tar.bz2) file? The makefile says you also need f77 which you already have installed and RATfortran. Keep commenting if you have any problems and when there are too many comments I will automatically open a private chat room for this question which has unlimited comments. – karel Aug 7 '17 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.