0

I tried to install xUbuntu 16.04 on my computer. The computer has two graphic card, one is a integrated graphic card called ASPEED Graphics Family [1a03:2000](rev 30), the other is GeForce GTX 1070. I want to use the integrated card to display, and use the GeForce GTX 1070 to do some computing with CUDA. And I use a monitor with VGA, didn't plug into the GTX 1070.

When installing the system xUbuntu 16.04, at first I was stuck in a black screen after I chose the "Install" in grub. I looked up some websites and found some solutions. When choosing "Install", press E to edit the command, and add nomodeset option after quiet splash, then I can enter the GUI to install system.

However, the installed system has a high resolution 1280 * 1024, but it flickers and its FPS is very low. Although the fresh rate it displays in the settings is 60 Hz, but in actual it's only 1 or 2 Hz.

By the way, another computer with same hardware can directly install system, and didn't ran into black screen. I really don't know why.

It might be the nomodeset option has lead to the low performance of my computer's display. But how to fix that?

Thanks.

  • nomodeset is a workaraound, not a fix. You need to install drivers for the GTX1070 (that you can insert and keep the boot option until the drivers are installed); the integrated one is new to me but apparently some old server graphics (??). Anyway, supposedly it has been supported for years. If you couldn't get video (without nomodeset) with only the integrated, use Nvidia only. – user692175 Aug 5 '17 at 1:51
  • Thanks for your comment. The integrated one is indeed a old server graphics. Your suggestion is using Nvidia only, if it means I have to connect my monitor with Nvidia card directly, instead of the VGA? There is only HDMI and DVI ports on the Nvidia card, however, my monitor can only be connected by VGA now. – Du Ang Aug 5 '17 at 6:06
0

Thanks for @MichaelBay's suggestions, it helped me a lot. Finally, I found it is indeed caused by the nomodeset option in /etc/defaults/grub. Which I have to add it to grub command when I install the system, otherwise all I get is a black screen. It seems that this option suppresses the performance of my integrated card, so it displayed low FPS and flickered.

I removed the nomodeset option according to @MichaelBay's comment. At first, I can't enter the system without this option when I just installed the system. But after I updated some drivers and softwares with sudo apt update and sudo apt upgrade, I could enter the system on logged in without nomodeset option in /etc/defaults/grub.

However, it's not a perfect solution for my computer. Every time when I start the system, I get a fancy strange display as you can see from the picture. If I press Ctrl + Alt + F1 to switch to command line interface, then press Ctrl + Alt + F7 to switch back to Xfce desktop, the display becomes normal, but there is still a little latency.

Fancy strange display after remove the <code>nomodeset</code> option

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.