1

I've gotten RDP through Remmina to connect to a Windows 8 guest running locally on my Ubuntu 17.04 installation on my home network using the Bridged Adapter setting in the VirtualBox Manager.

The problem I have is that I would like to be able to connect to the Windows 8 guest on the same machine when I'm at work. Unfortunately, there the Bridged Adapter doesn't work because of internal IT rules; the guest OS is blocked from seeing the internet.

My current thinking is that I can create a second connection in the VirtualBox Manager, a Host-Only Adapter, and use that to connect from my host to into the virtual machine. That way the guest OS can see the internet through the first connection via NAT and I can log into the guest through the host-only adapter.

Unfortunately, trying this, Remmina won't connect to the guest OS. I can see the local vboxnet0 network in the host ifconfig and the guest OS reports an IP address for the connection. I'm assuming, though, that Remmina is asking the internet to the connect to the IP address, rather than trying to connect to the guest running locally. Is there a way to accomplish this successfully? Or is there a better solution for what I'm trying to do?

Ultimately I'm hoping to use RDP to run individual applications on the host rather than having to turn on and log into Windows every time I need to run a Windows-specific application. This is mainly to be able to use Office365 on my regular Ubuntu installation.

Thanks in advance for your time, consideration, and advice. I'm looking forward to hearing back.

  • Have you tried configuring the VM in NAT mode rather than bridged mode, and forwarding the RDP port from host to guest across the VM's NAT interface? – steeldriver Aug 5 '17 at 2:04
  • Thanks very much for your quick response! That worked. For anyone else trying to resolve this particular problem, I set the settings for the guest OS in VirtualBox to forward port 5500 on the host machine to 3389 on the guest. Now Remmina connects directly into my guest OS using localhost:5500 as the IP and port for the connection. – Theron Muller Aug 5 '17 at 11:25
0

Running the guest OS in NAT networking mode and setting the port forwarding rules in the guest settings in VirtualBox so that port 5500 on my host forwards to 3389 on the guest allowed me to connect using localhost:5500 as the server IP and port in Remmina.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.