108

When updating I got the following message:

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used.
GPG error: http://dl.google.com/linux/chrome/deb stable Release:
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6494C6D6997C215E
W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6494C6D6997C215E
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done

I'm on Ubuntu 16.04 and currently using Chrome 60.0.3112.90. Any suggestions? I'm also trying to install libimobiledevice but apparently the system is not reading the repository where I just added the PPA as I can't install it. Thanks in advance for any help.

0

3 Answers 3

161

Apparently Google changed key for Chrome Linux repo. You can fix it by importing new repo key from Google:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Now you should be able to update the system without any errors.

This works for APT-based distros: Debian, Ubuntu and derivatives (Linux Mint, Kubuntu, Xubuntu, Lubuntu, etc.)

For more info and a fix for RPM-based systems (Fedora, CentOS, openSUSE, etc.) see official Google Linux repositories page.

8
  • 5
    Is there a solution for maintainer to automate this process? I wonder how many users will solve this problem as Linux isn't only for geeks today? Maybe Google could make update more smooth.
    – PocketSam
    Aug 5, 2017 at 3:37
  • @PocketSam There is a way for them to automate this process. Through an update. If they've stopped using their old key and you've missed the transition period where they used the old key but added the new key to the list, you've got a problem.
    – wizzwizz4
    Aug 5, 2017 at 9:20
  • 11
    There was no transition period: I run apt daily and this still happened.
    – Tobu
    Aug 5, 2017 at 10:27
  • 2
    Without google + stack-exchange (askubuntu, stack-overflow, etc.), this would be impossible even for experienced ("geeks"?) linux users. It's one of those very equalizing (humbling) issues that only appears to be easily resolved by experienced users. Sometimes ya just gotta google it -- as would be the case with any number of issues on any OS.
    – michael
    Aug 6, 2017 at 9:58
  • 1
    By some miracle, this solved a dropbox repo error: The repository 'http://linux.dropbox.com/ubuntu wily Release' does not have a Release file. Mar 8, 2018 at 9:02
32

try this:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 6494C6D6997C215E

and

sudo apt-get update
7

This should fix it for you

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

See: Google Chrome PPA upgrade invalid signature

Not the answer you're looking for? Browse other questions tagged or ask your own question.