1

I'm Using Ubuntu 17.04 on an old LG laptop. My goal is to disable the internal Wi-Fi (since it is old and slow), and use my USB Wi-Fi adapter to obtain better Wi-Fi. However, some errors occur when I'm trying to install the drivers from Edimax's site:

Following the instructions from the readme.txt file to run the install.sh file failed due to file permissions. I tried giving executable permissions to the entire directory using:

sudo chmod +X *

which gave most files/directories executable permissions, but not to install.sh.

ls -l output showing permissions of files

Even after trying to give permissions only to the specific file I had no luck.

Here is the output of lsusb:

Bus 001 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

And uname -r shows 4.10.0-28-generic.

  1. Why can't I change the permissions of that file?
  2. How to disable the internal Wi-Fi?
0

2 Answers 2

4

Please check to see if two possibly conflicting drivers are loaded:

lsmod | grep rtl

If you find that both rtl8192cu and rtl8xxxu are loaded, then blacklist one:

sudo -i
echo "blacklist rtl8192cu"  >>  /etc/modprobe.d/blacklist.conf
exit

You will also need a change to Network Manager:

sudo nano /etc/NetworkManager/NetworkManager.conf

Add a new section as follows:

[device]
wifi.scan-rand-mac-address=no

Proofread carefully, save and close the text editor.

After making these changes, reboot and let us hear the result.

3
  • possible to conflict latop's internal wifi module ?
    – guyd
    Commented Aug 4, 2017 at 21:48
  • 1
    Most certainly. Why not just use the internal??
    – chili555
    Commented Aug 4, 2017 at 21:49
  • hi, firstly - it WORKS !!! ( I'll be happy to understand what you did ), secondly- since it is an old laptop ( 10 year or so ), its wifi is 802g and very slow, and sometime disconnects when I used it as a windwos machine( i guess hardware issue ). Since your answer is great, but did not answered the original question I asked ( it is on hold )- I tought to open new Q and you'll answer it ?
    – guyd
    Commented Aug 5, 2017 at 4:39
1

chili555's answer is great, but only addresses the second of the two questions you ask, that is:

  1. How to disable the internal Wi-Fi?

I'm adding this answer to address your first question:

  1. Why can't I change the permissions of that file?

The reason you're not able to change the permissions of the install.sh file and some other files, as shown in your screenshot, is that you used the +X flag of chmod, instead of the +x one. The difference between the two flags is that x (lowercase "x") will set execution permissions for the specified files and directories, whereas X (uppercase "x") will set the permissions only for directories or files that already have execution permissions.

This is also stated in chmod's manpage, which you can access by running man chmod in your terminal. Here is the relevant part:

[...]
The letters rwxXst select file mode bits for the affected users: read (r),
write (w), execute (or search for directories) (x), execute/search only if the
file  is  a directory or already has execute permission for some user (X), [...]

Since your install.sh file does not already have execution rights, running chmod +X install.sh does nothing on it. If, instead, you had used:

chmod +x install.sh

then you would have given execution rights to install.sh, as you would expect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .