Trying to watch a VOB file. Installed MPlayer but it isn't opening. I am getting an error message saying 'Fatal Error':

Error in skin config file at line 6: PNG read error in usr/share/mplayer/skins/default/main

What does this mean

  • I'm still getting this error when running gmplayer (mplayer-gui 2:1.3.0-8build4) in ubuntu 19.10 (eoan). As a work-around, I can run mplayer from the command-line, or use smplayer (a different gui wrapper around mplayer).
    – michael
    Dec 24, 2019 at 6:45
  • @michael - Please see answer I just posted. It worked for me. Apr 12, 2020 at 7:08

6 Answers 6


The problem seems to be with the outdated Ubuntu skins package:


The PNGs are not in the correct format.

The Ubuntu packages mplayer and mplayer-gui are quite old.

Ubuntu has the outdated skin package.

I got it fixed with the following command:

cd /usr/share/mplayer/skins/default; for FILE in *.png; do sudo convert $FILE -define png:format=png24 $FILE; done
  • for FILE in *.png; do sudo convert $FILE -define png:format=png24 $FILE; done solved the problem thank you Mar 30, 2021 at 17:59

The problem is in the skins. Go to Beyond Linux' page about mplayer. Scroll down to "Skins" and download Clearlooks-1.9.tar.bz2. This was the latest version when I checked, on 2017-11-27.

Then, scroll down to "Skin Installation" and follow the instructions, but first delete /usr/share/mplayer/skins/default (which was a link to clearplayer). The instructions create a link to Clearlooks, the new skin directory.


http://muhdzamri.blogspot.com/2016/01/mplayer-gui-error-error-in-skin-config.html this helped me:

sudo add-apt-repository ppa:mc3man/mplay-skins
sudo apt-get update 
sudo apt-get upgrade
#sudo add-apt-repository -r ppa:mc3man/mplay-skins # You can remove the repository this way again. 

The error with skin disappered but a new error appeared: Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory

It seems that this second bug is not related to the skin's bug: https://bugs.launchpad.net/ubuntu/+source/libvdpau/+bug/1300215

So as I see it, I have to return to GNOME-mplayer :-((

Well, I do not know whether this has helped you...


May be it is too late to share the solution/answer here. I tried below command to install the mplayer and it worked absolutely fine for me.

sudo apt install mplayer mplayer-gui

May be it will help guys who might come here in future looing for the solution.


tl;dr still broken

I am also seeing

$ gmplayer
MPlayer 1.3.0 (Debian), built with gcc-7 (C) 2000-2016 MPlayer Team
Error in skin config file at line 6: PNG read error in /usr/share/mplayer/skins/default/main
Config file processing error with skin 'default'

Exiting... (Fatal error)


$ dpkg -s mplayer-gui | grep '^Version:'
Version: 2:1.3.0-7build2

$ dpkg -s mplayer-skins | grep '^Version:'
Version: 3.2

Relates to Launchpad bugs

  • 1218510 Fails to open due to: PNG read error in /usr/share/mplayer/skins/default/main
  • 1340454 Error in skin config file
  • 1575818 mplayer crashes on start
  • 1693410 gmplayer is broken

According to bug 1218510 comment #32,

This bug was fixed in the package mplayer-skins - 3.2build1

mplayer-skins (3.2build1) cosmic; urgency=medium

Then in comment #33

The new package http://de.archive.ubuntu.com/ubuntu/pool/multiverse/m/mplayer-skins/mplayer-skins_3.2build1_all.deb still doesn't work

Check your version of mplayer-skins package with command
dpkg -s mplayer-skins.


This solved the problem for me, overcoming all the "still broken" mentions. (files in the repo are actually broken). Taken from here.

  1. Get the deb package with the right pngs
wget https://launchpad.net/~mc3man/+archive/ubuntu/mplay-skins/+files/mplayer-skins_3.2.1~xenial_all.deb
  1. Install it.
gdebi mplayer-skins_3.2.1~xenial_all.deb

Others would add the ppa. It should work as well.

In addition, I would change the default skin. Blue is nicer, and it removes the warning messages stemming from file /usr/share/mplayer/skins/clearplayer/skin

$ cd ~/.mplayer
$ mkdir skins
$ ln -s /usr/share/mplayer/skins/Blue default

(this overrides the soft link /usr/share/mplayer/skins/default -> /usr/share/mplayer/skins/clearplayer). I do not know yet how to change the font size for the skin, if possible at all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .