2

I have recently installed Ubuntu 17.04 on a Dell Optiplex desktop which is using a USB wifi adapter to connect to the Internet. Model as listed by lsusb is Ralink Technology, Corp. MT7601U Wireless Adapter. It is branded LB Link on the unit itself.

The Wifi adapter is recognised and lists available Wifi networks but will not connect. I have tried with a variety of networks, both secured and unsecured. The network manager just shows the connecting state for a while then displays "Wifi network disconnected".

I have followed all the steps listed here: My WiFi adapter is not working at all, how to troubleshoot? with no result.

I have also looked at this post: Ralink MT7601U (148f:7601) Wi-Fi adapter installation which suggests installing a driver from here: https://github.com/art567/mt7601usta, however from what I can tell this driver has been integrated into the kernel since 4.2 and my kernel version is 4.10. Running modinfo mt7601u returns:

filename: /lib/modules/4.10.0-19 generic/kernel/drivers/net/wireless/mediatek/mt7601u/mt7601u.ko

System is clean install and fully updated.

The wifi adapter was able to connect using the previous Win7 install.

I am able to USB tether to the Internet with my Android phone. Ethernet connection also works fine.

Any suggestions about how to proceed would be appreciated.

  • Did you try this? askubuntu.com/questions/902992/… – chili555 Aug 4 '17 at 23:17
  • Thanks for the response. I've just tried it with no success unfortunately. – Jamie Aug 5 '17 at 8:04
  • Actually after making this change then removing and reinserting the device it worked! Thanks for your help - if you make it a full answer I will accept. – Jamie Aug 5 '17 at 9:39
6

For privacy reasons, the default settings for Ubuntu 17.04's network manager causes the MAC address of the USB Wifi device to change constantly. To fix this, you just have to edit a configuration file and then restart the network-manager service.

Open a terminal and run:

sudo nano /etc/NetworkManager/NetworkManager.conf

At the bottom of this file, copy and paste the following:

[device]
wifi.scan-rand-mac-address=no

Proofread carefully, save and close the text editor and run:

sudo service network-manager restart

You should be all set.

protected by Community Dec 30 '17 at 18:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.