2

I have just upgraded from Ubuntu 12.04 LTS to Ubuntu 14.04 LTS running GNOME. The upgrade went smoothly.

My problem is that I cannot tweak the themes with gnome-tweak-tool. When I load gnome-tweak-tool I get the following error messages:

WARNING : Shell not installed or running
INFO    : GSettings missing key org.gnome.nautilus.desktop (key computer-icon-visible)
WARNING : Error detecting shell
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/gtweak/tweaks/tweak_group_shell_extensions.py", line 284, in __init__
    raise Exception("Shell not running or DBus service not available")
Exception: Shell not running or DBus service not available
WARNING : Shell not running

The gnome-tweak-tool windows are available but theme parameter changes in the Appearance tab do not work (you can write them in, but no effect and the default is restored upon exit).

The same problem occurs whether logged in with Metacity, Compiz, Ubuntu or GNOME.

When I run: if pgrep gnome-shell; then echo GNOME shell is running; else echo Nope not running;fi it answers Nope not running

When I log in as another user with root privileges, the same error and gnome-tweak-tool dysfunction occur.


I have now solved this problem. I can launch a functional Gnome Tweak Tool under Ubuntu 14.04 (or on another computer running 16.04 which presented the same problem) by entering "gnome-tweak-tool" in the Alt + F2 command line from any of the desktop flavours (GNOME, Ubuntu, Compiz, Metacity), but NOT from either a normal or a root terminal (which is widely implied on the web to be a valid method)!

  • 1
    Root terminal is a bad idea, but I'm suprised that a normal terminal does not work... What version of gnome-tweak-tool (and gnome-shell) are you using? – Wilf Aug 6 '17 at 8:46
0

reply below is too long for a "comment":

When I log in in the "GNOME" environment, I can enter "gnome-search-tool" (but not "sudo gnome-search-tool) in a terminal to get a functional Gnome Search Tool. I can then log off and log in with another environment (Ubuntu, Metacity, Compiz) and my new Gnome tweak settings will be there. But I cannot load a functional Gnome Search Tool from a terminal in Ubuntu, Metacity or Compiz, I have to do it from the Alt + F2 command line.

Ubuntu 14.04 LTS running under Gnome Shell, Gnome version 3.9.90, gnome-shell 3.10.4-0ubuntu5.2, gnome-tweak-tool 3.10.1-2ubuntu1 [strange that when I say "sudo gnome-session --version" I get the above version but when I check the file /usr/share/gnome/gnome-version.xml I see version 3.8.4 - maybe because I uninstalled Ubuntu Desktop and reinstalled only Gnome Shell]

But exactly the same behaviour for Gnome Tweak Tool is seen on another computer Ubuntu 16.04 LTS running under Ubuntu Desktop, Gnome version 3.18.2, gnome-shell-common 3.18.5-0ubuntu0.3 (gnome-shell not installed), gnome-tweak-tool 3.18.1-1 ["sudo gnome-session --version" does not return a value, above is from the xml file]

About the only things these computers have in common is that they are both portables (one lap-top and one netbook), both seven years old and both have been recently upgraded from Ubuntu 12.04 LTS.

  • Is this an answer? – muru Aug 7 '17 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.