4

After a installation via aptitude, how does one actually run the program? (via nautilus or even terminal)

for example, i'm now trying to use a program called pulseview. for this i installed a package called sigrok using sudo apt-get install sigrok

sigrok is already in the repository. The sigrok package also contains pulseview. I believe sigrok is the CLI and pulseview the GUI, but that assumption could be wrong.

The installation worked perfectly, but how do I now run the program?

What I have tried

  • I first searched for the application, but didn't find it. I also tried to find it via Software Centre but no luck there :(

  • I then tried to see if installation actually worked by doing the same again. It informed me that the latest version was already installed. then i thought i might need to install pulseview seperately, via aptitude. but also on that i got informed that the latest version was already installed.

  • So tried (sudo) ./sigrok and pulseview but no such file or directory (as one would expect).

Sorry to ask someting, which will probably be so obvious, but when I search for topics the explanation stops after the install line and no added info on how to run it. I actually thought I had made a similar topic before, but even in that topic there was no answer on this part.

Thanks in advance.

  • thanks so much!.. sigrok didn't work, but pulseview did! again thanks! – Matthieu Kints van Aug 3 '17 at 16:42
  • 1
    The command-line interface is actually named sigrok-cli. Sorry about that. – Nonny Moose Aug 3 '17 at 16:45
6

Sigrok is a metapackage which pulls in pulseview, the GUI (as you thought), and sigrok-cli, the command-line interface to sigrok. To run the GUI, (located in /usr/bin/pulseview) it should suffice to run pulseview (not ./pulseview) because /usr/bin is on your search path.

| improve this answer | |
  • oke, that is usefull to understand, something i then clearly yet don't understand is the exact meaning of ./ – Matthieu Kints van Aug 3 '17 at 16:45
  • 3
    ./command runs the binary file named command in your current working directory. – Nonny Moose Aug 3 '17 at 16:48
  • additionally something i don't understend, is why do i NOW find pulseview in a search under applications while it wasn't there before. I have the feeling (and had this before) i need to run a program at least once before it ends up in a search in applications, which would be strange. do i need to restart nautilus or something after an install to find te program? – Matthieu Kints van Aug 3 '17 at 16:48
  • I doubt it. It showed up right away for me. Either it was a glitch or it was in the process of adding it to the menu. – Nonny Moose Aug 3 '17 at 16:50
  • oke. that is thus something i understoon completely inverse.. my thought was that: "program name" would look locally, and ./program name in the standard search path. – Matthieu Kints van Aug 3 '17 at 16:51
3

As Nonny Moose commented, when you install a new package via apt or aptitude, unless you deliberately install the package elsewhere, it will install to the default location (/usr/bin and /usr/local/bin are quite common). This path is included in what's called your PATH.

When you run a command from your terminal, it will first check your PATH for what you are looking for. If you specify a path (as you were doing with ./my_file), it means "Look in this directory and run this file".

As you can see in this example, I asked my system to tell me where exactly it would find sigrok if I asked, to which it tells me where it looked and failed to find it (because I don't have it installed).

$ ~: which sigrok
/usr/bin/which: no sigrok in (/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/home/user/bin)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.