I am trying to use the Windmill Testing Framework over https. When I run windmill firefox http://www.example.com the Windmill IDE comes up fine. When I run windmill firefox https://www.example.com the IDE fails. (I have installed pyopenssl in my Python virtual environment. https failed completely before I did this.)

I suspect that this is because I haven't installed the Certificate Authority (.crt file) for Windmill itself.

The Windmill team provide instructions for installing the Windmill CA on Windows and Mac, but not Linux, let alone Ubuntu :(

The instructions on https://help.ubuntu.com/8.04/serverguide/C/certificates-and-security.html and How do I install a root certificate? suggest that I need both a .crt file and a .key file, but only a .crt file is provided, and seems to be all that is needed on other OSes.

How can I install the provided .crt file? (Or, what is the Ubuntu equivalent of the provided Windows/Mac instructions?)


1 Answer 1


The .crt file is already installed in the Firefox profile created by Windmill. No additional steps are required.

You can verify this by running Firefox through Windmill, then opening Edit (menu) | Preferences (menu option) | Advanced (tab) | Encryption (tab) | View Certificates (button) | Authorities (tab), and scrolling down the list to confirm Windmill is listed.

If for some reason it isn't (due to a bug) you could try adding it manually. In general Linux/Ubuntu applications don't use a central resource for certificate authorities, so you can follow the directions above and click the Import... button. The Windmill CA instructions include links to the latest .crt file.

This hasn't actually solved my problem, but eliminates this as the cause and answers the question.

  • my original problem was because I was running windmill firefox https://www.example.com instead of windmill firefox https://www.example.com ssl
    – lofidevops
    Jan 23, 2012 at 9:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .