0

I have Xubuntu 16.04 and have recently bought a new keyboard -- MODECOM VOLCANO GAMER. I plugged it and it works great except the fact that CTRL, ALT and WINDOWS KEY work the same way as SHIFT does. It means I ma unable to use most keyboard shortcuts.

I tried a solution posted on this website, but unfortunately it did not work: CTRL and ALT works as SHIFT?

sudo lsusb output:

Bus 002 Device 003: ID 0dd8:ac00 Netac Technology Co., Ltd 
Bus 002 Device 002: ID 2109:0812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 006: ID 0bda:57cc Realtek Semiconductor Corp. 
Bus 001 Device 005: ID 0489:e09f Foxconn / Hon Hai 
Bus 001 Device 003: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 258a:1006  
Bus 001 Device 002: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
1

I think problem is with default anti-ghosting setting. I am using Mint 18.2 and I had same problem with MODECOM VOLCANO GAMER keyboard on my system. By default keyboard have 87 anti-ghosting keys enabled. After I switched to 6 anti-ghosting keys, it works like charm (Fn + SL | key between PS and PB, it has 6/104key label on it).

| improve this answer | |
  • Darn it worked! Thank you! I was pulling my hair over this and I would compile drivers myself or bougth new keyboard before I would try this! :D – n.podbielski Oct 22 '19 at 17:11
0

i feel that you should look into have they correct keyboard layout in use. I could be wrong with that, but have had problems with that myself before and that solved it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.