1

I installed lxde on ubuntu server 16.04.3.every thing was fine untill i purged lxde and re-installed it.now i can start lxde with startx,but not with using lightdm or startlxde.

In lightdm it says failed to start session

I tried moving ~/.Xauthority and re installing LXDE.no result,i couldn't find any answer on internet so please don't duplicate my question.

Any help would be appereciated.

EDIT: when i install ubuntu-deskop,the problem is fixed and i can login to LXDE.but when i purge ubuntu-desktop,the problem is back again.

EDIT2: I've also purged,removed all packages that where leftover,autoremoved,autocleaned then install LXDE again,but no luck.

4
  • why not purge all and run autoremove, autoclean and reinstall? sometimes it may work
    – saviour123
    Aug 3, 2017 at 12:02
  • i've also tested it.i've purged it,removed all packages that where leftover,autoremoved all,autocleaned all and installed again.
    – Ali SH
    Aug 3, 2017 at 13:51
  • Verify that you have lightdm-gtk-greeter installed. Otherwise, the screen will freeze on login for some LightDM versions.
    – GTRONICK
    Aug 3, 2017 at 13:54
  • @GTRONICK,it doesn't freeze,it says failed to start session
    – Ali SH
    Aug 3, 2017 at 15:02

1 Answer 1

0

I had a similar problem in Ubuntu 18.04 after installing lxde, I would get "failed to start session" when I put in the correct password. (Putting the incorrect password gave a different error.) I did apt-get install lubuntu-desktop and this solved it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .