0

Problem: The built-in microphone does not work (sound recording, Skype, Video conferencing apps, etc.). Although all the apps recognize the built-in microphone as "Built-in analog stereo", none of them can actually get any sound from it. The microphone worked before on Kubuntu 15.04 and under Windows 7. The interesting thing is that when I open the Sound settings and go to the 'Input' tab, I can see that the "Internal microphone" does not hear my voice, but it does hear a loud hand clap.

What I have tried:

  • Checked that the mic is not muted in sound settings.
  • Changed the "Input volume" to over 100% in "Sound settings > Input".
  • Changed the "Input volume" to over 100% in PulseAudio volume control (Input Devices).
  • Unlocked and muted one channel with pavucontrol.

Hardware/software:

  • Lenovo Thinkpad Edge E330 Ubuntu 16.04.2 LTS
  • uname -r 4.10.0-27-generic
  • MATE Desktop Environment 1.12.1
  • aplay -l

    **** List of PLAYBACK Hardware Devices **** card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog] Subdevices: 0/1 Subdevice #0: subdevice #0 card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0

  • dmesg | egrep -i "sound|audio|snd"

9.393579] thinkpad_acpi: Console audio control enabled, mode: monitor (read only) [ 9.408050] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269VC: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker [ 9.408053] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0) [ 9.408054] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x15/0x0/0x0/0x0/0x0) [ 9.408055] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0 [ 9.408056] snd_hda_codec_realtek hdaudioC0D0: inputs: [ 9.408058] snd_hda_codec_realtek hdaudioC0D0: Mic=0x18 [ 9.408059] snd_hda_codec_realtek hdaudioC0D0: Internal Mic=0x12 [ 9.428090] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915]) [ 9.434521] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8 [ 9.434570] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9 [ 9.434614] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10

  • lspci | grep -i audio

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

0

Not good having Pulseaudio levels above 100%, likely to cause audio distortion

Try checking ALSA level settings

alsamixer -c 0 --view capture

use spacebar to set capture for recording device
mic boost and capture level settings can be adjusted with arrow keys

Or use command:

amixer -c 0

for text output if you need more help finding settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.