0

I am trying to run two chemistry programs together that need the PATH environment changed in order to find one another. The manual says:

Under the UNIX operating systems, R.E.D. looks for the "GAMESS", "Gaussian" and "RESP" binaries and scripts using the "which" UNIX command. Thus, one should update the "$PATH" environment variable.

The binaries and files of interest are gamess.0n.x, rungms, and ddikick.x and are all located in /home/david/Bin/red/RED-III.52-Tools-Files. Following the advice found in parts of other threads I did the following:

  1. Opened the bashrc with gedit ~/.bashrc
  2. Added the line PATH=$PATH:/home/david/Bin/red/RED-III.52-Tools-Files
  3. Ran the software

The output of the program, which I will include below, suggests that the "which" command was unable to locate the binary. Any advice would be greatly appreciated!

                 * Software checking *
gamess.0n.x  (n = 0->9)                 [ NOT FOUND ]
rungms                                  [ NOT FOUND ]
ddikick.x                               [ NOT FOUND ]
resp                                    [ NOT FOUND ]
ERROR: Some program(s) cannot be executed

As a note, I found a similar issue on the program's forum (the only difference is they are using gaussian instead of gamess) but I have such an elementary understanding of PATHs and the "which" function that it is difficult to understand. Hopefully, the example is helpful.

I Am getting the following error. Can someone help?

* Software checking * 
gaussian [ NOT FOUND ] 
resp [ NOT FOUND ] 

You need to set up your .bashrc file if you use bash shell or .cshrc if you use tcsh/csh.

Here is a part of my .cshrc:

------------------------------------------ 
setenv SOFT /usr/local 
setenv AMBERHOME /usr/local/amber10 
setenv GAMESS_SCR /Big-disk/0QM_SCR 
setenv GAUSS_SCRDIR /Big-disk/0QM_SCR 
setenv g03root /usr/local 
source /usr/local/g03/bsd/g03.login 
set path = ($path $AMBERHOME/exe $SOFT/g03 $SOFT/gamess $SOFT/firefly)  
------------------------------------------

If I use the "which" UNIX command, I get:

[fyd_at_lynx ~]$ which g03 
/usr/local/g03/g03 
[fyd_at_lynx ~]$ which resp 
/usr/local/amber8/exe/resp
  • 1
    Have you restarted the shell (e.g. closing and reopening the terminal) or manually sourced the changed file by running source ~/.bashrc? – Byte Commander Aug 2 '17 at 16:45
  • I thought that was the problem at first too. I tried closing and reopening the terminal and when that didn't work I tried restarting my computer. – DWK Aug 2 '17 at 16:53
  • 1
    Could you please edit your question and include the outputs of which gamess.0n.x rungms ddikick.x, echo $PATH and ls -l /home/david/Bin/red/RED-III.52-Tools-Files? – Byte Commander Aug 2 '17 at 16:56
0

The path is incorrect. /home/david/Bin/red/RED-III.52-Tools-Files is the source of the RED ESP program that is looking for GAMESS.

Instead, add the PATH=$PATH:/home/david/Bin/gamess to your bashrc. The path that was added to your bashrc file was essentially telling the program where to find itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.