2

It used to work fine: I would close the lid and Ubuntu would nicely suspend and resume when I opened the lid.

Now I find that it does not. What happens first, I don't know, but on reopening the lid, the computer boots up as if from a cold start. The same thing happens when I run sudo pm-suspend, so it has nothing to do with the lid settings--it's just that the suspend command seems to simply reboot.

I have been messing with libinput around the time when it happened, installing and uninstalling it and alternating with the synaptics driver, but I'm unsure if this is related.

  • OS ver: Linux kernel 4.10.0-28-generic #32~16.04.2-Ubuntu
  • System: Dell XPS 13 9350 (late 2015), i7 Skylake processor.
2

Similar model (Dell XPS 15 9550), same problem. Updating the BIOS to version 1.2.29 fixed this.

For future reference:

You can easily install BIOS updates on Debian using the package fwupdmgr.

0

Well just as I finally decided to Ask Ubuntu, it stopped happening of course. Unsure what I did, but I followed some guidance from other, similar questions. One of which was to do a full poweroff (shut down, and restart with power button), rather than reboots. The other was to run another sudo apt dist-upgrade which seemed to also update some kernel headers.

6
  • Please delete the question, as the problem fixed itself and you are not sure what exactly solved the problem. – user68186 Aug 2 '17 at 16:39
  • 1
    I worry that this might get me blocked. It may also be a guideline for others. – bluppfisk Aug 2 '17 at 16:44
  • 1
    I already flagged it as "a problem that went away and can't be reproduced". What probably happened was an update that solved it. Always fully update after installing. – user692175 Aug 2 '17 at 18:04
  • 1
    In fact, I had. I just went and did it again. It most certainly did not work for a week. I didn't think kernel headers would be updated weekly, anyway I'm not sure where to find information about the recent kernel updates – bluppfisk Aug 3 '17 at 6:54
  • the issue just started happening again (yesterday) and I don't seem to have updated any headers recently. – bluppfisk Sep 3 '17 at 7:01
0

It's very strange and it may have worked only for me, but whenever this happens to me, I shut down the computer entirely (power off). Upon restarting, the computer suspends/resumes normally.

I read this somewhere else but cannot find the source again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.