1

I just got a new laptop just for Ubuntu (Acer aspire e15). Upon installation, I forgot to disable secure boot from Windows and installed Ubuntu 16.04, wiping out windows 10. Now Ubuntu won't boot and Windows 10 is gone. I tried boot-repair and still nothing. Disabling secure boot through Bios is not an option. Anyone can help me?

  • Please run the Boot Repair utility from the Ubuntu installer booted in "try before installing" mode and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here. This will give us more details about your configuration, which is required to base an answer on more than guesswork. Secure Boot is probably not the issue, and accessing the firmware setup utility will likely do you no good. – Rod Smith Aug 5 '17 at 0:42
1

Remove all boot media. This should cause to display "no device to boot to" or a similar message and forces a full POST rather than fastboot sequence after reboot. You can access UEFI setup at POST and disable secureboot that way. Do not forget to remount all your boot media.

  • Thanks, I did that, was able to disable secure boot, reinstalled Ubuntu (clean install), but it still won't boot. I ran boot-repair and still nothing. url paste2.org – Liv Aug 2 '17 at 16:51
  • sorry, paste2.org/x16kHGsD – Liv Aug 2 '17 at 17:07
  • FYI, you can always access UEFI regardless of the installed OS or no OS at all. The default fast boot setting makes it hard to press the required key in time (it must be almost simultaneously with the powering on). That said, now everything looks fine (except the Windows entries that are nop longer required. Please access UEFI settings > boot order and see if you can find and select as firt priority an Ubuntu entry. If not, you may need additional steps (due to a "broken" UEFI). – user692175 Aug 2 '17 at 18:17
  • Some motherboards defer input initialisation until OS boot. Hence advice to remove all boot media. – Erkin Alp Güney Aug 2 '17 at 18:44
  • 1
    solved with ubuntuforums.org/showthread.php?t=2289754 – Liv Aug 2 '17 at 19:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.