0

This question already has an answer here:

I'm completely new to linux. If someone could make out from the image whats wrong it would be really helpful. Also I'm getting that red icon on the top panel.

I tried running these code :-

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update

The above code made that red icon go away after I rebooted but when I used the sudo apt-get upgrade after using sudo apt-get update command it popped up back again.

sudo apt-get -f install gives me this output error

Also I have referred to this thread (How do I resolve unmet dependencies after adding a PPA?) but to no avail.

After running the sudo dpkg -- configure -a it gives me following error.

instincts@Instincts:~$ sudo dpkg --configure -a
[sudo] password for instincts: 
dpkg: dependency problems prevent configuration of ppa-purge:
ppa-purge depends on aptitude.

dpkg: error processing package ppa-purge (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of aptitude:i386:
aptitude:i386 depends on libapt-pkg4.12 (>= 0.8.16~exp12ubuntu6).
aptitude:i386 depends on libboost-iostreams1.46.1 (>= 1.46.1-1).
aptitude:i386 depends on libc6 (>= 2.4).
aptitude:i386 depends on libcwidget3.
aptitude:i386 depends on libept1.4.12.
aptitude:i386 depends on libgcc1 (>= 1:4.1.1).
aptitude:i386 depends on libncursesw5 (>= 5.6+20070908).
aptitude:i386 depends on libsigc++-2.0-0c2a (>= 2.0.2).
aptitude:i386 depends on libsqlite3-0 (>= 3.6.5).
aptitude:i386 depends on libstdc++6 (>= 4.6).
aptitude:i386 depends on libtinfo5.
aptitude:i386 depends on libxapian22.

dpkg: error processing package aptitude:i386 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
ppa-purge
aptitude:i386

Any help would be appreciated. Thank you.

marked as duplicate by Eric Carvalho, karel, muru, Pilot6, Zanna Aug 4 '17 at 10:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    You probably will find the solution here. – Russo Aug 2 '17 at 15:09
1

You can try fixing the broken dependencies using the following command:

sudo apt-get -f install

sudo dpkg --configure -a

Then run this again:

sudo apt-get -f install

You can find in details how to fix the dependency error in this thread.

  • I have updated my question. Plz have a look. – Pranav Chaudhari Aug 3 '17 at 10:31
  • Sometimes it's easier just to reinstall ubuntu. I had unmet dependency errors a while back and the only way to fix it was to reinstall ubuntu. – Russo Aug 3 '17 at 12:42
0

Try this:

apt-get update
apt-get upgrade

and if you are running latest Ubuntu

apt-get dist-upgrade

and then

apt-get -f install
  • "sudo apt-get update" works fine. "sudo apt-get upgrade" and "sudo apt-get dist-upgrade" share the same error which i have posted in the question above (1st image link). Also error for "sudo apt-get -f install" is posted. Thanx for trying to answer though. – Pranav Chaudhari Aug 3 '17 at 10:51
  • Try to go to repository manager (ubuntu software) and check if main and contrib repositories are checked. – FK-VH Aug 3 '17 at 10:55
  • U mean this right ?? I had those checked. – Pranav Chaudhari Aug 3 '17 at 11:12
-1

I reinstalled ubuntu and obviously it solved the error.

Not the answer you're looking for? Browse other questions tagged or ask your own question.