0

i would like to install this github program. https://github.com/ChrisLuck/ut71dmm

made directory (in home) ut71dmm
unzipped the downloaded github .zip file into that directory
tried to followed the readme from there.

  • cd into ut71dmm
  • clone hidapi: git clone git://github.com/signal11/hidapi.git
    but tgot the following error msg: No command 'clone' found

also tried:

  • git clone hidapi: git clone git://github.com/signal11/hidapi.git
    error: to many arguments.

and

  • git clone git://github.com/signal11/hidapi.git
    seemed to work.. at first.
    Cloning into 'hidapi'... remote: Counting objects: 2006, done. remote: Total 2006 (delta 0), reused 0 (delta 0), pack-reused 2006 Receiving objects: 100% (2006/2006), 2.72 MiB | 425.00 KiB/s, done. Resolving deltas: 100% (1174/1174), done.

but upon make: i got the following error msg:

  • gcc -I./hidapi/hidapi -Wall -g -c pkg-config libusb-1.0 --cflags hidapi/libusb/hid.c -o hidapi/libusb/hid.o Package libusb-1.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libusb-1.0.pc' to the PKG_CONFIG_PATH environment variable No package 'libusb-1.0' found hidapi/libusb/hid.c:47:20: fatal error: libusb.h: No such file or directory include libusb.h>

i understand i messed up.. there :(

and would really appreciate some support to get this up and running..

Kind regards

Matthieu

1

You need to install the libusb-1.0-0 development package. You can install the package using the apt-get package manager:

sudo apt-get install libusb-1.0-0-dev

needed an additional dependency:

# for a additional missing libudev dependent library. 
sudo apt-get install libudev-dev
| improve this answer | |
  • thank you for a quick response. so i just did.. but: clone hidapi: git clone git://github.com/signal11/hidapi.git still leaves the same error message: co command clone found. and when i use make: also the same: – Matthieu Kints van Aug 2 '17 at 11:03
  • gcc -I./hidapi/hidapi -Wall -g -c pkg-config libusb-1.0 --cflags hidapi/libusb/hid.c -o hidapi/libusb/hid.o Package libusb-1.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libusb-1.0.pc' to the PKG_CONFIG_PATH environment variable No package 'libusb-1.0' found hidapi/libusb/hid.c:47:20: fatal error: libusb.h: No such file or directory #include <libusb.h> – Matthieu Kints van Aug 2 '17 at 11:07
  • which is strange.. additionally i would like to say that i believe i had libusb already installed in the past, just not sure if it was libusb or libusb-dev. – Matthieu Kints van Aug 2 '17 at 11:20
  • You would have installed the binary library files only not the header files for development activity. – AmeyaVS Aug 2 '17 at 11:22
  • but this time i definately did! just get stuck on the "No command 'clone' found" error. i believe that to be the major issue. – Matthieu Kints van Aug 2 '17 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.