13

New Ubuntu 16.04.2 installation. Uninstalled the default libreoffice installation. Then I installed libreoffice 5.4.0.3 from this PPA:

sudo add-apt-repository ppa:libreoffice/ppa

Now all icons are missing from toolbars:

libreoffice calc toolbar

Is this a bug or a funk setting? Any thoughts on how to reset the toolbar to get the typical configuration? I already tried the basic stuff (rebooting, disable/enable toolbars, etc.)

  • Just adding the PPA and update/upgrade would be sufficient. No need to unistall and I'm afraid you may have uninstalled something you shouldn't. And no, I don't know how to solve it and it may well be off topic. – user692175 Aug 2 '17 at 6:40
  • Although your advice might be accurate, I've always uninstalled first and have never seen this behavior. Could just be a bum install. Thank you for reply. – James Aug 2 '17 at 6:47
  • I am also facing the same problem. Libreoffice was upgraded to version 5.4.0.3 through the "software update" process automatically in first week of August. – neelanshu Aug 11 '17 at 11:09
29

Tools > Options > LibreOffice > View

Switch Icon style from Automatic to another style in dropdown.

1
sudo apt install libreoffice-style-galaxy

will do. You could also install other libreoffice-style-* packages.

1

I have the same problem. I solved this in this way

1) install other style: in my case sudo apt-get install libreoffice-style-human

2) change the style configuration: Tools > Options > LibreOffice > View

In my case I've updated with this ppa too, and broke in the same way. I suppose that I have one incompatibility with the Libreoffice-style-mint or something like this.

Good luck!!

1

Tools > Options > LibreOffice > View

The problem is selecting large icon size. Change it auto. My icons came back.

  • Hello and welcome to AU. I do not see any difference between your answer and the first one. In such a case, it is better to upvote the answer than to add another one. This increases the visibility of the selected answer without addind clutter in the site. – Marc Vanhoomissen Oct 16 '18 at 12:09
0

Had the same issue, the solution was installing breeze icon theme.

apt install libreoffice-style-breeze

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.