I know this is a common issue, and I've already searched and tried all I've found, but nothing works. I've been trying to install Ubuntu 16.04 on my desktop but I can't seem to make it work. I've tried both with USB and DVD (both checked for intregrity) with no differences.

The USB/DVD boots, and it shows the UEFI selection screen (try Ubuntu, install, check disk, etc...). Whichever I choose, it goes straigth to a blank screen.

I've tried booting in BIOS (legacy) mode, and the only difference is I don't get the selection screen, just a brief purple screen with the little guy on the bottom, and then again, blank screen.

I've also tried with the following grub boot methods: nomodeset, nolapic, acpi=off, and different combinations of them. Some combinations shows some processes going on, but no luck, some of them go to a kernel panic.

Here are my specs: Gigabyte Gigabyte GA-970A-D3P (no on-board video) AMD FX6300 Sapphire RX460

Thank you!

As far as I get

  • 1
    Are you dual booting or single boot?
    – saviour123
    Aug 1 '17 at 15:00
  • The HDD has windows installed but I plan to wipe everything out. I couldn't install ubuntu yet..
    – Teo Iovine
    Aug 1 '17 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.