1

I've been up and down this forum site trying to make this external drive I'v setup to have rw/rw/rw so no matter what computer I plug it in to I can access it. By access I mean use it as a git backup(push/pull), save documents to it and of course read from it. It works fine on my home computer but when I plug it in at work or to other computers the folders I've created on it are still locked. They show a lock symbol on it.enter image description here

I tried doing the following but it has failed in making my folders and all sub folders to be accessible from another work station even though it says everyone can "Create/Delete files".

gksudo nautilus

I've tried plugging in my external drive to another computer that I have root access to and I can add files as that way but I have to be root. I don't have root on my work computer so I have to find a way to setup this drive to be accessible. I've also plugged it into a computer I have root access and typed

sudo chmod 666 -R /media/shane/BlackBox

This still doesn't work. There are a few other commands I tried but I can't recall every single one of them. I've been stuck on this for 3 days now doing my research on here the best I can but have failed. I need some help.

  • Use my pathlld tool to diagnose. git clone https://github.com/waltinator/pathlld.git – waltinator Aug 1 '17 at 13:43
  • sudo chmod 666 -R /media/shane/BlackBox does not alter the USER that owns it. Mind that directories NEED "7" so your command messed the permissions up big time, – Rinzwind Aug 1 '17 at 13:45
4

Did you try to change the owner of the folders ?

by typing:

sudo chown -R $USER /your_folder

After that you can type in your terminal:

ls -l

or to go your_folders->properties

To see if there is any change concerning the owner of the folder, It should be the case.


To fix the errors by your chmod use

find . -type d -print0 | xargs -0 chmod 0755 
find . -type f -print0 | xargs -0 chmod 0644 

to fix that.

| improve this answer | |
  • chown ? chmod is for file permissions – tgkprog Aug 1 '17 at 13:40
  • chmod will changes the permission for all files in the folder but when you add the -R it also modify the directory (see the documentation) permission ;) – Loic L. Aug 1 '17 at 13:46
  • 2
    @lolo hope you do not mind the editing. Have an upvote ;-) – Rinzwind Aug 1 '17 at 13:47
  • haha @Rinzwind why suggest when we can edit. better strategy – tgkprog Aug 1 '17 at 13:58
  • @lolo Thanks for the help as well to the others. This worked great except I noticed for my repositories I have on the external drive when I type the commands above to fix errors it says chmod: changing permissions of './Home/Projects/bla/bla/repo.git/objects/long hash code here' : Operation not permitted – shanedora Aug 1 '17 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.