0

I'm trying to install Eclipse cpp oxygen into Ubuntu 14.04. After extracting the file and executed [eclipse] executable file, i'm met with the following errors. Greatly appreciate any advice fr the community. Thanks!

JVM terminated. Exit code=1
/usr/bin/java
-Dosgi.requiredJavaVersion=1.8
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
-jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
-os linux
-ws gtk
-arch x86_64
-showsplash /opt/eclipse//plugins/org.eclipse.epp.package.common_4.7.0.20170620-1800/splash.bmp
-launcher /opt/eclipse/eclipse
-name Eclipse
--launcher.library /opt/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.500.v20170531-1133/eclipse_1624.so
-startup /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.appendVmargs
-exitdata 24e806b
-product org.eclipse.epp.package.cpp.product
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
-jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar 
2
  • And you are using java version 1.8?
    – Rinzwind
    Aug 1, 2017 at 9:36
  • hi @Rinzwind, i figured out that it's a java version issue. I've since installed java 1.8 and is able to start eclipse already. Thank you!
    – rainfrost
    Aug 2, 2017 at 2:11

1 Answer 1

1

The notice "requiredJavaVersion=1.8" means you are not using at least Java 1.8.

See for instance How to install OpenJDK 8 on 14.04 LTS? on how to install 1.8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.