0

Evening.

I recently upgrade Ubuntu to 17.04 and ran into a problem. I can log into any user that existed in my machine, but only when dropping to the terminal. I cannot do that by regular means in the Ubuntu splash screen. I started looking into it and looks like the package gnome-session is not getting installed because there is a missing dependency for it. The exact problem is that somewhere during the upgrade, the following package had a problem: 3.24.0-0Ubuntu1.

I tried installing, purging and autocleaning several times but I keep getting the following problem:

gnome-session: Depends: gnome-session-bin (>=3.24.0-0Ubuntu) but 3.18.1.2-1Ubuntu1.16.04.2 is to installed.

Has anybody run into this issue?

NOTE: I tried installing another of the dependencies and I got the following:

gnome-session-bin: Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or libgles2.

I tried another command here to see if I could reinstall my desktop.

apt-get install --reinstall ubuntu-desktop and got the following error:

ubuntu-desktop: Depends: ubuntu-session but it is not going to be installed Recommends: unity8-desktop-session but it is not going to be installed E: unable to correct problems, you have held broken packages.

Thanks, Raf

  • Did you also try sudo apt-get install -f --reinstall ubuntu-desktop? -f is for "try to automatically fix broken dependencies" – derHugo Aug 1 '17 at 5:26
  • Indeed I did. I jumped into google and some people recommend doing this with aptitude. I am installing it right now to give it a shot. – user167582 Aug 1 '17 at 5:33
0

Fix:

Used aptitude instead of apt. Aptitude had no problem install ubuntu-desktop from scratch. After that, the account login problems went away.

Hope this helps somebody else.

Raf

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.