0

I just picked up this device (Acer r11 Chromebook) a couple days ago. I installed Linux just fine using crouton (unity so xubuntu?) I have been trying to browse the web, specifically Udemy.com and Google Docs, as I got the rig to teach myself SQL and Data Querying. The Linux install went fine... except there are a couple problems that are preventing me from continuing:

1) When I use the NerSurf Web Browser, the app doesn't display Web pages correctly. Including this site, Ask Ubuntu and Udemy.com, I haven't tried Google docs yet but I imagine that would be even worse. Maybe there is a fix so I can still use NetSurf?

2) I am unable to download and install the proper version of another web browser, chrome.

I installed Linux from developer mode using the command: [sudo sh ~/Downloads/crouton -e -t unity] or something very close to that, after downloading the crouton file. I am posting this from my phone since the NetSurf app cannot display the human verification page correctly when I post this question from my Acer in the NetSurf app... pretty frustrating.

I have the file-roller app and even downloaded the chrome-linux.zip and extracted it... not sure how to install it from there. I ran the command wget dl.google.......stable_current_1386.deb as this one YouTube video demonstrated. The terminal then returned

Resolving dl.google....... Connecting to dl.google........ connected HTTP request sent, awaiting response... 404 Not Found 2017-07-31 08:51:41 ERROR 404 : Not Found.

The ... was actually text. The ........ represent where I shortened the output.

Any help would be greatly appreciated. I am a beginner with Linux but I do have limited experience with C++ and Python. Thanks

  • It's saying the file you tried to download is not working in the way you want it to. Try running this command from the terminal sudo apt install chromium-browser. Once it is complete, look for chromium (the open source version of Google Chrome) in your menu. At the very least, it is functional and will get you a browser that works for downloads and displaying websites. – ThatGuy Jul 31 '17 at 16:01
  • Ok, do you know what command I should use? – Bitz Jul 31 '17 at 16:02
  • 2
    @Bitz The command is in their comment. And there's nothing preventing you from downloading Chrome's .deb file and install that (your Ubuntu should be 64-bit). At least Firefox is also available in the repositories and other can be easily installed as well. – user692175 Jul 31 '17 at 16:15
  • Thatguy updated his comment actually. Before he just said the first line. His post worked wonders for me. Just ran chromium the first time. How do I mark the comment left by Thatguy as the answer? Thanks a bunch btw – Bitz Jul 31 '17 at 16:17
  • @michaelbay makes a good point. Firefox is also available. I just made an assumption that you'd prefer chrome/chromium. There's no need to mark mine as the answer, just answer your own question with the steps you took to rectify the problem. Mark your answer as accepted, and you'll even get a badge for it ;) – ThatGuy Jul 31 '17 at 16:21
1

Answer: I installed Chromium using the Terminal command:

sudo apt install chromium-browser

Using the Chromium browser has none of the issues I was experiencing while using the NetSurf browser.

You guys are helpful and responsive. Keep it up.

  • This is a comment, not an answer. You can say something along this lines: "I ended up installing Chromium with ... command..." – user692175 Jul 31 '17 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.