0

Before we start I have researched this question and no answers help me. I have a laptop where the internal drive has failed. I have installed ubuntu on an external usb 1tb hard drive and it has been working well. Last night I closed down and today I get message - no boot device found - I can boot from live cd usb stick and see all data on external drive. External drive is ok but just will not boot - i have tried fsck and boot-repair - how can I just reinstall grub and make this drive boot again - thanks

0

OK no replies or assistance here so I tried to re-install from a Clonezilla image. Clonezilla told me system was set to boot in EFI mode but no EFI partitions, my hard drive is ext4. I checked the BIOS and for some reason factory defaults had been reset I enabled the option to boot in Legacy mode and ensured first boot option was usb hard drive - all works well now. I answer my own question in the hope it may help others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.