I installed Ubuntu 16.04.1 server on my laptop a few months ago, added enough X11 pieces to get the GUI working, and just enough networking packages to get wifi (and wired ethernet, of course) working.

I don't remember the details about the networking part, but it's been working fine for months.

I am sure that I don't have Network Manager (or Gnome, for that matter) installed. This is a fairly old-school, mostly-CLI box. I'm also sure that there is no /etc/wpa_supplicant.conf file (I do have /sbin/wpa_supplicant, but I'm not sure how to tell whether it's used anywhere).

We had a power blip this afternoon, and my laptop has not been able to connect to the wireless network since then. (It's totally possibly the card got fried, but it was not plugged in, so I'm optimistic there). I have not checked the wired connection yet. Other devices are fine, so the problem isn't the router.

While it's booting, it pauses at "A start job is running for Raise network interfaces" for about 5 minutes, then gives up because that failed.

Running ip a produces:

3: wlp2s0: mtu1500 qdisc mq state DOWN group default qlen 1000 link/ether b8:76:... brd ff:ff:ff:ff:ff:ff (along with details about other connections that basically look right).

I've tried different variations of ifup/down and dhclient, along with setting a static IP address. They all just time out.

The error message from doing an ifdown/ifup is "No DHCPOFFERS received. No working leases in persistent database - sleeping."

I used google to track down a command for monitoring ports 67 and 68 using tcpdump, and I haven't seen any traffic.

Running sudo lshw -class network shows

*-network ...built-in network adapter... *-network description: Wireless interface product: AR9485 Wireless Network Adapter vendor: Qualcomm Atheros physical id: 0 bus info: pci@0000:02:00.0 logical name: wlp2s0 version: 01 serial: ${MAC address} width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless configuration: broadcast=yes driver=ath9k driverversion=4.4.0-87-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn resources: irq:17 memory:c0500000-c057ffff memory:c0580000-c058ffff *-network DISABLED ... the virtual bridge to either LXC or docker ... (configuring Docker also fails at startup. I don't think it's related, but a message about "Failed to listen on Docker socket" shows up pretty prominently while I'm waiting for the basic network failure to time out).

systemctl status docker.socket shows that the "Control process exited, code=exited status=216" I suspect that this is a side-effect of the real problem, but it seems worth mentioning. (I have the latest 1.12 installed, but I don't really do anything with it).

This is the part that seems interesting to me, though I may be reading too much into it:

The lan adapter on my router has a MAC address that looks like: xx:xx:xx:xx:xx:00

It has two vlans configured, at xx:xx:xx:xx:xx:08 and xx:xx:xx:xx:xx:09. /etc/network/interfaces is configured with the wpa-ssid that should tell it to connect to xx:xx:xx:xx:xx:09.

The end of dmesg has a bunch of messages that look like:

wlp2s0: authenticate with xx:xx:xx:xx:xx:05 wlp2s0: send auth to xx:xx:xx:xx:xx:05 (try 1/3) wlp2s0: send auth to xx:xx:xx:xx:xx:05 (try 2/3) wlp2s0: send auth to xx:xx:xx:xx:xx:05 (try 3/3) wlp2s0: authentication with xx:xx:xx:xx:xx:05 timed out

I don't know where that 05 address came from.

This is all with kernel 4.4.0-87, which I really haven't exercised much. For grins, I tried booting 4.4.0-78, which is the oldest version that I have installed. That seems to have the same issues. (I didn't spend a lot of time there, just verified the lack of networking and that dmesg has the same flavor of errors).

So far, the only way I've been able to get any feedback at all about what's going on is when I turned wifi off. When I did that, both dhclient and tcpdump exited because the network interface went away.

So I'm pretty confident that my system knows the card is there and thinks that it's accepting packets. Beyond that, I'm out of ideas. Any thoughts or suggestions?



For reference, whatever the problem was got fixed by rebooting the wireless router one more time. So reading this was a complete waste of your time. I'm sorry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.