I'm a not talented Ubuntu user and I have a problem with wi-fi and Ubuntu 16.04.

It started with 14.04, when an update failed (it stopped before finishing) and the Wi-Fi disappeared from the networking tab. I tried something without success, then I decided to upgrade to 16.04 (via LAN).

By mistake I kept an old configuration file, but everything worked well except that Wi-Fi still does not work. I disabled Secure Boot from bios (and tried some other random actions) with basically no effect: while the Enable Wi-Fi option was present in the networking tab, there was the indication Wi-Fi is disabled under Wi-Fi Networks. The Network driver selected in Software & Updates > Additional drivers is Broadcom 802.11 from bclwm-kernel-source.

I tried to follow what is suggested in Qualcomm Atheros Device [168c:0042] (rev 30) Wi-Fi driver installation

But the only result was that Enable Wi-Fi disappeared from the networking menu.

How can I fix it?

Thanks for the comments.

I am afraid that following Qualcomm Atheros Device [168c:0042] (rev 30) Wi-Fi driver installation messed up everything.

I add the result of lspci -knn | grep Net -A3; rfkill list

02:00.0 Network controller [0280]: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
    Subsystem: Dell BCM4352 802.11ac Wireless Network Adapter [1028:0019]
    Kernel modules: wl, bcma

I'm sorry if I'm wrong but I have the impression my question is different from Why do I get "Required key not available" when install 3rd party kernel modules or after a kernel upgrade?. In my case Secure Boot has been disabled from bios since the very beginning.

Additional information result of sudo apt install --reinstall bcmwl-kernel-source

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/1.544 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 939933 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu1~1.1_amd64.deb ...
Removing all DKMS Modules
Done.
Unpacking bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.1) over (6.30.223.271+bdcom-0ubuntu1~1.1) ...
Setting up bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.1) ...
Loading new bcmwl-6.30.223.271+bdcom DKMS files...
Building only for 4.4.0-87-generic
Building for architecture x86_64
Building initial module for 4.4.0-87-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.4.0-87-generic/updates/dkms/

depmod....

DKMS: install completed.
modprobe: ERROR: could not insert 'wl': Invalid argument
update-initramfs: deferring update (trigger activated)
Processing triggers for shim-signed  (1.32~16.04.1+0.9+1474479173.6c180c6-1ubuntu1) ...
Secure Boot not enabled on this system.
Processing triggers for initramfs-tools (0.122ubuntu8.8) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-87-generic

Install broadcom-sta-dkms instead Try the following commands

sudo apt-get update
sudo apt-get install broadcom-sta-dkms
sudo modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
sudo modprobe wl

it will work for you make sure your internet is on :)

  • Thank you. Unfortunately it did not work (I also tried to reboot and restart netw manager). Nothing appeared in the network tab and sudo modprobe wl yielded modprobe: ERROR: could not insert 'wl': Invalid argument – Giuseppe Falci Jul 31 '17 at 7:39
  • In Software & updates -> Addidtional drivers the menu gives as the only alternative Continue using a manually installed driver – Giuseppe Falci Jul 31 '17 at 8:19
  • install synaptic - sudo apt-get install synaptic then you could check inside synaptic what wireless tools works for you – Dhiresh Budhiraja Jul 31 '17 at 13:21
  • you could purge bcmwl-kernel-source or could go to wiki.debian.org/wl for further assistance – Dhiresh Budhiraja Jul 31 '17 at 13:22
  • i recommend to purge bcmwl-kernel-source – Dhiresh Budhiraja Jul 31 '17 at 13:24

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.