1

I have the same freeze problem detailed here Ubuntu 16.04 freezes with 4.10 kernel:

  • Ubuntu version 16.04
  • NVidia graphic card: GeForce GTX 1060 6GB
  • Nouveau driver

Everything works fine with 4.8.0.58-generic kernel. I would like to continue to use Nouveau driver.

Today I tryied with 4.10.0-28-generic and I can login but if I try to logoff my notebook freeze. I tryied to logoff using menu (icon on top right) and "sudo poweroff" and the problem is the same. My notebook freeze also if I press CRTL + ALT + F1 to open TTY.

Suggestions?


Update: 19 August

Same problem with 4.10.0-30-generic and 4.10.0-32-generic.


Update: 2 September

Same problem with 4.10.0-33-generic


Update: 21 September

Same problem with 4.10.0-35-generic

PS: I didn't try yet all the solutions suggested by Karsus

0

Updated to make answer more standalone:

Your problem is likely related to ACPI.

Try editing acpi_osi kernel parameters according to the suggestions of this question.

Instructions on doing it temporarily (to test it) and permanently (if it fixes your problem) can he found here:

To temporarily add a boot parameter to a kernel:

  1. Start your system and wait for the GRUB menu to show (if you don't see a GRUB menu, press and hold the left Shift key right after starting the system).
  2. Now highlight the kernel you want to use, and press the e key. You should be able to see and edit the commands associated with the highlighted kernel.
  3. Go down to the line starting with linux and add your temporary boot parameter acpi_osi=! acpi_osi='Windows 2009'" to its end.
  4. Now press Ctrl + x to boot.

To permanently add a boot parameter to a kernel:

Always test with a temporary change before making a permanent change. I soft-bricked my laptop because I got overconfident with such changes.

Here is what one has to do to permanently edit boot parameters in order to fix ACPI:

The process to do so is described, for grub2, in more detail in this answer:

# open a terminal
$ gksudo gedit /etc/default/grub
# Find the line starting with GRUB_CMDLINE_LINUX_DEFAULT and append foo=bar to its end. For example:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! acpi_osi='Windows 2009'"
# Save the file and close the editor.
# Finally, start a terminal and run:
$ sudo update-grub

To see the kernel parameters of a running kernel type:

$ cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-4.10.0-33-generic root=UUID=221a0401-7879-4389-a6fe-fea2935f35e5 ro quiet splash acpi_osi=! "acpi_osi=Windows 2009" vt.handoff=7
  • I modified boot param for 4.10.0-33-generic but 1) I can open TTY but I can't write on it: no login and there is only the blick cursor 2) shutdown works. Solution is half-good because I need to use terminal. Thanks anyway – dani_bs Sep 6 '17 at 7:02
  • Have a check at this bumblebee issue. There are several different suggestions. Maybe the modeset suggestion of that comment helps as well. Since you got a partial fix it looks like ACPI is part of your problem. – Karsus Sep 6 '17 at 9:40
  • Using kernel 4.10.0-37-generic and kernel param acpi_osi=! acpi_osi="Windows 2009" it works! – dani_bs Oct 17 '17 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.