1

Till last night i was running a dual boot Linux mint 17 and Windows 10 on my hard drive, mostly using Linux and Windows only 5% of the time. Last night i turned Windows on for the first time in good 2-3 month, of course it started automated update (maybe upgrade?!) it was late so i left it there to finish up and when i turned my laptop on this morning i had:

Error: no such partition Entering rescue mode... Grub Rescue>

No access to Windows or Linux

I had live linux usb and through that i've been searching internet for solution - nothing worked so far and i'm starting to get a little scared that windows wiped my linux partition as when i go to Disks & Gparted i cant see any linux partitions apart from Swap and unallocated free space!!!

I've tried using Boot repair - it finishes and lets me know all is fine.

I've tried changing the boot partition (have about 5) with all partitions returning unknown file system.

I've spent over 8 hours researching and am unable to find a solution.

So i'd like to know - have i lost all my data from linux ( i can stil mount windows partition though linux live), if so can i recover anything? Can i get into windows, finish the update somehow and then install linux again?

Thanks in advance for any help/advice provided

P.S. Below is a link to screenshot of Disk & Gparted https://photos.app.goo.gl/HRXKdIScBUBD10kE3

6
  • 1
    Questions related to windows are off topic. So are questions related to versions that are NOT official or current Ubuntu. I would start with a "boot repair" and see if Windows only removed grub.
    – Rinzwind
    Jul 29, 2017 at 16:01
  • 1
    MInt is off topic here. Jul 29, 2017 at 16:02
  • Off topic, as commented already. That said, the way to avoid this is to install both OSes in UEFI mode, as it should be always whenever available.
    – user692175
    Jul 29, 2017 at 16:06
  • Right, apologies, i'll pop over to linux mint forum. I naively thought both systems are similar when it comes to repair/installation issues. Thanks for quick replies in any case
    – Vidrom
    Jul 29, 2017 at 16:13
  • Chances are your Mint installation still exists, but GRUB has been disrupted in some way. Posting the URL provided by Boot Repair would help; without it, people can only guess as to the root cause. It's possible that my rEFInd boot manager on a USB flash drive or CD-R would enable the system to boot. As others have said, Mint is off-topic here, so you should take these suggestions as a way to improve your question on a Mint forum. (Mint is derived from Ubuntu; the off-topic nature of Mint here is policy, not technical.)
    – Rod Smith
    Jul 29, 2017 at 16:22

1 Answer 1

1

When using dd to erase a USB on /dev/sdd I accidentally used /dev/sdb and wiped out the first 1 MB of my second hard disk. This erased the MBR (Master Boot Record) and partition table.

TestDisk can be downloaded here and has versions for Windows and Linux. It goes through every byte of your hard drive to analyze what partition type it is and rebuilds the partition tables. I used TestDisk to successfully recover all my data.

From the website, TestDisk can:

  • Fix partition table, recover deleted partition
  • Recover FAT32 boot sector from its backup
  • Rebuild FAT12/FAT16/FAT32 boot sector
  • Fix FAT tables
  • Rebuild NTFS boot sector
  • Recover NTFS boot sector from its backup
  • Fix MFT using MFT mirror
  • Locate ext2/ext3/ext4 Backup SuperBlock
  • Undelete files from FAT, exFAT, NTFS and ext2 filesystem
  • Copy files from deleted FAT, exFAT, NTFS and ext2/ext3/ext4 partitions.

Not the answer you're looking for? Browse other questions tagged or ask your own question.