1

My /etc/security/limits.conf (55 & 56):

*               hard    nofile          65535
*               soft    nofile          8192

I am trying to:

sysctl -p --load /etc/security/limits.conf

And received this errors:

root@petersamokhin:~# sysctl -p --load /etc/security/limits.conf
sysctl: /etc/security/limits.conf(55): invalid syntax, continuing...
sysctl: /etc/security/limits.conf(56): invalid syntax, continuing...

I have just copypasted this lines from google. Why this error occured ? How to fix this? Thanks.


Also tried:

sysctl -p --load /etc/security/limits.conf

and tried to delete # End of file, tried to delete spaces, tried with sudo. No result.

  • Try this sudo sysctl -p --load=/etc/security/limits.conf – George Udosen Jul 29 '17 at 15:53
  • @George already tried. Same result – Peter Samokhin Jul 29 '17 at 15:54
  • Please add sudo – George Udosen Jul 29 '17 at 15:55
  • ok I see the problem you have a syntax error in the file your loading! – George Udosen Jul 29 '17 at 15:55
  • @George with sudo same result too. This file was default. I only added this two lines in the end of file – Peter Samokhin Jul 29 '17 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.