1

I have a HP 255 G4 notebook with a Realtek WiFi adapter. I need to run some commands in the terminal in order to get the wifi working. The problem is that after every update, the system discards the changes made by me and the wifi stops working. It is not such a problem when I'm at home and can connect via ethernet, but when I'm away and can use only wifi it is a bit of a problem. So can I somehow get the OS to not change these settings?

In general to get wifi working I use:

sudo apt-get remove rtlwifi-newdkms
reboot
sudo apt-get install git build-essential
git clone http://github.com/lwfinger/rtlwifi_new
cd rtlwifi_new
make
sudo make install
reboot
sudo modprobe -rv rtl8723be
sudo modprobe -v rtl823be ant_sel=2
sudo echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtlbtcoex.conf

Or is there a way of creating an executable file that can run the commands above and to contain files from rtl8723be_new folder that are needed?

Ubuntu version is 16.04.02 LTS, kernel version 4.10.0-28-generic.

Before installing this driver I've searched the internet for solutions, and this is the one to work for me. It is possible to get another solution, I just haven't found it.

the result of sudo apt purge rtlwifi-new-dkms is "package can not be found" (I'm using Bulgarian, so I'm not copying the output result). I don't run the uninstall command, because I need wifi for the moment, and if I do it, I won't be able to use networking. The output of grep... command is:

/etc/modprobe.d/rtlbtcoex.conf:options rtl8723be ant_sel=2
[   20.774353] rtlwifi: loading out-of-tree module taints kernel.
[   20.774483] rtlwifi: module verification failed: signature and/or required key missing - tainting kernel
[   20.804759] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[   20.804763] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[   20.896118] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[   20.896127] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[   20.896135] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[   21.070430] rtl8723be: Using firmware rtlwifi/rtl8723befw_36.bin
[   21.078507] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   21.079068] rtlwifi: rtlwifi: wireless switch is on
[   21.897621] rtl8723be 0000:02:00.0 wlo1: renamed from wlan0
[   31.202106] rtl8723be 0000:02:00.0 wlo1: disabling HT as WMM/QoS is not supported by the AP
[   31.202109] rtl8723be 0000:02:00.0 wlo1: disabling VHT as WMM/QoS is not supported by the AP
[ 3659.493015] rtlwifi: rtlwifi: wireless switch is on
[ 3662.476260] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[ 3662.476264] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[ 3662.476296] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[ 3662.476299] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[ 3662.476306] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[ 3666.277764] rtl8723be 0000:02:00.0 wlo1: disabling HT as WMM/QoS is not supported by the AP
[ 3666.277769] rtl8723be 0000:02:00.0 wlo1: disabling VHT as WMM/QoS is not supported by the AP
[ 4037.305961] rtlwifi: AP off, try to reconnect now
[ 4045.075961] rtl8723be 0000:02:00.0 wlo1: disabling HT as WMM/QoS is not supported by the AP
[ 4045.075965] rtl8723be 0000:02:00.0 wlo1: disabling VHT as WMM/QoS is not supported by the AP
[ 7658.772095] rtlwifi: rtlwifi: wireless switch is on
[ 7661.007611] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[ 7661.007618] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[ 7661.007652] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[ 7661.007656] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[ 7661.007663] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[ 7664.946554] rtl8723be 0000:02:00.0 wlo1: disabling HT as WMM/QoS is not supported by the AP
[ 7664.946558] rtl8723be 0000:02:00.0 wlo1: disabling VHT as WMM/QoS is not supported by the AP
  • 2
    What is the Ubuntu version and the kernel version? You can install this driver using DKMS. Or maybe you don't need this driver any more since it is included in the kernel. – Pilot6 Jul 29 '17 at 11:24
  • 1
    You can find the Ubuntu version in the output lsb_release -a and the kernel version in the output of uname -r. – David Foerster Jul 29 '17 at 13:19
  • I have 16.04.2 and a 4.10 kernel - now at -27. I also have trouble with a Realtek wifi chip ( 8821ae) see askubuntu.com/questions/940342/… . Going back to a 4.8 kernel fixes the error. I have commented on an 8821 bug report. – NickT Jul 30 '17 at 18:00
2

You don't need any drivers from source for the 4.10 kernel. You need to remove them. Run

sudo apt purge rtlwifi-new-dkms
cd rtlwifi_new
sudo make uninstall

The wireless adapter will be managed by the in-tree module an should work OK unless you blacklisted it somewhere.

If Wi-Fi doesn't work add the output of grep rtl /etc/modprobe.d/*; dmesg | grep rtl to your question.

  • So I've uninstalled the driver. After reboot - no wifi... In taskbar network menu there is not the wireless option/menu... Think I should reinstall the default driver now, but honestly I don't know how?! I'm writing from a phone so I'm not able to give more details right now. Please tell me how to re-install/re-activate the default driver. Probably to get it work I should change the ant selection... – Методи Шотлеков Aug 1 '17 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.