2

RTL8723BE Bluetooth not working. Specifically, the driver cannot be detected at all:

  • hciconfig -a returns absolutely nothing.
  • hcitool dev just returns Devices: (nothing)

Already tried using the solution in this question: RTL8723BE Bluetooth does not work

Prior to installing the lwfinger solution, the bluetooth can be turned on but cannot detect other devices.

Before showing the script for the bluetooth driver, here is what I ran for the Wifi driver (from a fresh install):

## Wifi driver
sudo apt-get install firmware-realtek wireless-tools
## But range is poor so
mkdir ~/git-clones
cd ~/git-clones
git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new.git
make
sudo make install
sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2
sudo ip link set wlan0 up
sudo iw dev wlan0 scan
echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

Approach 1

Now here is what I ran specifically for the bluetooth driver:

## Bluetooth driver
cd ~/git-clones
git clone -b troy https://github.com/lwfinger/rtl8723au_bt.git
cd rtl8723au_bt
make
sudo make install
sudo reboot

Approach 2

Also attempted to install the rar file from this link: https://github.com/troy-tan/driver_store/tree/master/bluetooth/8723BE . Unpacked this rar and then sudo make install -s as prescribed in the README file. Still nothing happens.

Where did I go wrong?

1
  • I'm having the same problem. Still didn't find a solution for the bluetooth... Aug 2, 2017 at 3:21

1 Answer 1

0

The bug is fixed with this kernel:

http://kernel.ubuntu.com/~jsalisbury/lp1788997

as long as you select antenna 1:

modprobe rtl8723be ant_sel=1

Make sure you have that in config too:

sudo /bin/sh -c 'echo "options rtl8723be ant_sel=1" >> /etc/modprobe.d/rtl8723be.conf'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.