0

I flashed the img ubuntu-16.04-preinstalled-server-armhf+raspi3.img.xz onto an sd card and boot it up on an Raspberry Pi 3 Model B. Since I'm doing this headlessly, I have to connect it through ssh. Anyway, I want to run the server through wlan, so I did a bit of research online and edited /etc/network/interfaces. This is what it looks like:

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet static
     address 192.168.1.135
     netmask 255.255.255.0
     gateway 192.168.1.1
     wpa-essid "somessid"
     wpa-psk "somekey"

As soon as I removed the LAN cable, i get Destination Host Unreachable when I try to ping both IP. Sometimes, it doesn't even work if I plug the LAN cable back on. I'm new to both Ubuntu Server and Raspberry Pi and I know this has been asked a lot but I haven't been able to get it done (believe me, this is the 9th time that I flash my sd card.) Thank you for your help.

  • I believe it is wpa-ssid and you also need dns-namervers if you expect to reach the internet. – chili555 Jul 28 '17 at 21:43
  • I mean I still can connect with the wlan0 IP with the LAN cable on, but not without it. I tried dns nameservers 8.8.8.8 192.168.1.1 but it still doesn't work – leScepter Jul 28 '17 at 21:53
  • Once you correct your interfaces file and reboot with the ethernet detached, does it connect? – chili555 Jul 28 '17 at 22:33
  • I rebooted with corrected file and ethernet detached and connect the server with wlan0 ip, all I get is connection timed out – leScepter Jul 28 '17 at 22:57
  • image – leScepter Jul 28 '17 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.