15
W: The repository 'http://ppa.launchpad.net/gnome-terminator/ppa/ubuntu yakkety Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/gnome-terminator/ppa/ubuntu/dists/yakkety/main/binary-i386/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
2
  • 2
    And what are you doing? What command did you run? What did you try to solve it? Obviously you searched Google for the error before coming here, so what did that tell you? Please edit your question and explain what you were doing and what you've tried. – terdon Jul 28 '17 at 13:32
  • apt has very bad error messages. Has not Release file could also mean you do have a typo in your address or no internet connection at all. You should check if ppa.launchpad.net/gnome-terminator/ppa/ubuntu displays the files in a browser. – CatMan Jul 28 '17 at 13:33
44
  • Open Software & Updates, Other Software tab.
  • find the PPA definition that contains "gnome-terminator"
  • select it and click Edit
  • change the Distribution field from yakkety to xenial
  • save the changes
  • update the software database when prompted
  • problem solved

Source: http://ppa.launchpad.net/gnome-terminator/ppa/ubuntu/dists/

9
  • 4
    for me it was 'bionic' and I changed to xenial, fixed the issue, but I don't understand why it doesn't have the bionic dist? – sangress Jan 20 '19 at 15:24
  • 6
    @sangress If you look at http://ppa.launchpad.net/gnome-terminator/ppa/ubuntu/dists/ you'll see that there's not a bionic distribution directory for this software. – heynnema Jan 20 '19 at 15:28
  • @sangress it was the exact same for me. – marcogmonteiro Mar 9 '19 at 19:13
  • 2
    Just test it with Ubuntu 20.04 focal fossa and it worked flawlessly. – Reginaldo Santos Sep 3 '20 at 13:29
  • 2
    @ZahraShahrouzi Yes. Just change focal to xenial. – heynnema Feb 27 at 13:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.