0

there is no description of how to do this on the github wiki or sourceforge wiki just how to

There is a file

/etc/default/ddclient

# Configuration for ddclient scripts
# generated from debconf on Thu Jul 27 17:32:33 ACST 2017
#
# /etc/default/ddclient

# Set to "true" if ddclient should be run every time DHCP client ('dhclient'
# from package isc-dhcp-client) updates the systems IP address.
run_dhclient="false"

# Set to "true" if ddclient should be run every time a new ppp connection is
# established. This might be useful, if you are using dial-on-demand.
run_ipup="false"

# Set to "true" if ddclient should run in daemon mode
# If this is changed to true, run_ipup and run_dhclient must be set to false.
run_daemon="true"

# Set the time interval between the updates of the dynamic DNS name in seconds.
# This option only takes effect if the ddclient runs in daemon mode.
daemon_interval="300"

If I go to

sudo systemctl edit --full  ddclient.service

a file is created with these parameters

# Automatically generated by systemd-sysv-generator

[Unit]
Documentation=man:systemd-sysv-generator(8)
SourcePath=/etc/init.d/ddclient
Description=LSB: Update dynamic domain name service entries
Before=multi-user.target
Before=multi-user.target
Before=multi-user.target
Before=graphical.target
Before=shutdown.target
After=local-fs.target
After=remote-fs.target
After=network-online.target
After=systemd-journald-dev-log.socket
Wants=network-online.target
Conflicts=shutdown.target

[Service]
Type=forking
Restart=no
TimeoutSec=5min
IgnoreSIGPIPE=no
KillMode=process
GuessMainPID=no
RemainAfterExit=yes
ExecStart=/etc/init.d/ddclient start
ExecStop=/etc/init.d/ddclient stop

This doesn't run at boot though..? I can only get the service to start manually with either sudo etc/init.d/ddclient start or sudo systemctl start ddclient.service

4

You want sudo update-rc.d ddclient enable

  • Awesome thankyou, could you explain pls how you know that? – phaseform Jul 27 '17 at 11:49
  • I noted running sudo systemctl edit --full ddclient.service after breaks this service – phaseform Jul 27 '17 at 11:59
  • Please note if you do not know what you are doing, do not edit configs you know nothing of. I know this by having run into the same issue years ago. – Jahil Khalfe Jul 28 '17 at 7:04
  • Thank you for your help, but there is no manual for systemd, how I'm I supposed to configure this service then?! – phaseform Aug 16 '17 at 3:30
  • 1
    Open your terminal and run man systemd. – Jahil Khalfe Aug 16 '17 at 8:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.