1

Getting this error when trying to install the module:

E: Package 'libapache2-mod-fastcgi' has no installation candidate

All solutions I found suggest adding 'multiverse' to apt sources, but they see to wokr only for previous version of Ubuntu. I have this (among others) in my /etc/apt/sources.list by default:

deb http://gb.archive.ubuntu.com/ubuntu/ zesty multiverse
# deb-src http://gb.archive.ubuntu.com/ubuntu/ zesty multiverse
deb http://gb.archive.ubuntu.com/ubuntu/ zesty-updates multiverse
# deb-src http://gb.archive.ubuntu.com/ubuntu/ zesty-updates multiverse

I am assuming this module has been dropped from Ubuntu, but what would be the replacement for it? The proxy_fcgi module doesn't do the trick, as rewrites are not working out of the box and modifying them to add the [P] flag is not an option for me.

  • 1
    You could download it from packages.ubuntu.com/xenial/libapache2-mod-fastcgi and sudo dpkg -i <package name> to install it; it's under LTS, not sure how wise that is, probably friends on your use-case. – pbhj Jul 27 '17 at 13:27
  • my use case is a development VM, so I'll give it a try. Thanks! – Okneloper Jul 27 '17 at 16:28
  • 1
    worked perfectly so far! @pbhj feel free to post this as an answer – Okneloper Jul 27 '17 at 17:34
1

Download the missing package from http://packages.ubuntu.com/xenial/libapache2-mod-fastcgi and sudo dpkg -i <package name> to install it; it's under LTS so should get updates and fixes, but you'll have to manually check for them and apply them in the same way (or add a "xenial" entry in your apt .list files).

Not sure how wise this is, probably depends on your use-case; maybe not good for a production server!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.