2

I created a deb package that has:

Package: foo
Depends: libssl1.0.1 (>= 1.0.1)

This works fine on trusty or jessie but it won't work on zesty since libssl1.0.2 is a different package than libssl1.0.1.

Is there a way to specify on the deb package that either depends on libssl1.0.1 OR libssl1.0.2? or is there a workaround other than creating two distinct deb packages?

4

From the Debian Policy Manual, Chapter 7: Declaring relationships between packages:

In the Depends, Recommends, Suggests, Pre-Depends, Build-Depends, Build-Depends-Indep and Build-Depends-Arch control fields of the package, which declare dependencies on other packages, the package names listed may also include lists of alternative package names, separated by vertical bar (pipe) symbols |. In such a case, that part of the dependency can be satisfied by any one of the alternative packages.

[...]

For example, a list of dependencies might appear as:

Package: mutt
Version: 1.3.17-1
Depends: libc6 (>= 2.2.1), exim | mail-transport-agent

So, presumably:

Depends: libssl1.0.1 (>= 1.0.1) | libssl1.0.2
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.