1

I'm on Ubuntu 11.10, have installed Monodevelop-2.8.5, on the first run, it said the xsp2 server was missing, I installed that.

Now, the application builds successfully, but, when I run my application, it just opens google chrome (and not my application). What is the problem?

The application output is,

Registering application:
    Host:          any
    Port:          any
    Virtual path:  /
    Physical path: /home/tarun/MyWebsite/MyWebsite/
xsp2
Listening on address: 127.0.0.1
Root directory: /home/tarun/MyWebsite/MyWebsite
Listening on port: 8080 (non-secure)

When I try to open, 127.0.0.1:8080 on chrome, I get the following error :

Oops! Google Chrome could not connect to 127.0.0.1:8080

But, 127.0.0.1 works just fine.

  • Could you please tell how you run the application? What happens if you try to open the URL http://127.0.0.1:8080 with another browser while the application is running? Do you have a firewall running on your host? – tohuwawohu Jan 9 '12 at 9:52
  • Does the example asp.net application work? To test this, cd to usr/share/asp.net2-demos/ and run the #xsp command. – tohuwawohu Jan 9 '12 at 9:55
  • @tohuwawohu there is no such file or directory and I run the application in mono by ctrl+f5 – badZoke Jan 9 '12 at 10:43
  • @tohuwawohu so when I run the application only chrome opens and not my applicaiton, now while the application is running and I open another tab and enter 127.0.0.1:8080 it navigates to Default.aspx of the project. – badZoke Jan 9 '12 at 10:52
0

It looks like to be a chrome-related problem, so you should set any other browser as default browser on your system. Maybe monodevelop has a config option regarding the web browser to start, so you should check monodevelop's config options too.

  • how in the world do you know all this? – badZoke Jan 9 '12 at 13:16
  • @Tarun: it's all the same with those IDEs :-) – tohuwawohu Jan 9 '12 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.