Just installed Ubuntu 16.04 on an Acer Aspire S and everything's working great except the wifi. I can connect to open hotspots, but when I authenticate to my WPA2 router at home it fails.

This is with an Atheros QCA6174...

% lspci -knn | grep Net -A3; rfkill list
01:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    Subsystem: Lite-On Communications Inc QCA6174 802.11ac Wireless Network Adapter [11ad:0807]
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader [10ec:5229] (rev 01)
1: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: acer-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

% dmesg | grep -e ath10 -e wlan
[    7.215916] ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    7.509020] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:01:00.0.bin failed with error -2
[    7.509034] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01:00.0.bin failed with error -2
[    7.510267] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[    7.510269] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
[    7.513370] ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 11ad:0807
[    7.513371] ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[    7.513875] ath10k_pci 0000:01:00.0: firmware ver WLAN.RM.2.0-00180-QCARMSWPZ-1 api 4 features wowlan,ignore-otp,no-4addr-pad crc32 75dee6c5
[    7.579414] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 6fc88fe7
[    9.734242] ath10k_pci 0000:01:00.0: htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    9.826346] ath10k_pci 0000:01:00.0 wlp1s0: renamed from wlan0

Never had any problem with connecting with my other Ubuntu systems. Here's the modprob...

[   55.988872] wlp1s0: authenticated
[   55.989002] ath10k_pci 0000:01:00.0 wlp1s0: disabling HT as WMM/QoS is not supported by the AP
[   55.989004] ath10k_pci 0000:01:00.0 wlp1s0: disabling VHT as WMM/QoS is not supported by the AP
[   55.995359] wlp1s0: associate with 00:24:7b:64:77:bc (try 1/3)
[   55.998581] wlp1s0: RX AssocResp from 00:24:7b:64:77:bc (capab=0x411 status=0 aid=1)
[   56.001232] wlp1s0: associated
[   56.001280] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready
[   59.456829] wlp1s0: deauthenticated from 00:24:7b:64:77:bc (Reason: 1=UNSPECIFIED)
[   63.649930] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready

Seems it authenticates successfully but then deauthenticates right after? Tried replacing my /lib/firmware/ath10k as mentioned in https://askubuntu.com/a/718430/717711 but that caused my wireless to stop working entirely so reverted those changes.

Unfortunately I'm now a bit stumped. Help appreciated!

  • I know it seems extremely simple but have you tried rebooting, or restarting the network-manager? – NerdOfCode Jul 26 '17 at 4:14
  • Yup. Tried rebooting several times, 'sudo /etc/init.d/networking restart', and restarting the network-manager. – Damian Jul 26 '17 at 15:41
  • sudo network-manager restart? Or did the answer below fulfill your question? – NerdOfCode Jul 26 '17 at 17:10
  • Nope, as I mentioned restarted network-manager and the below didn't help. – Damian Jul 27 '17 at 1:54

Figured it out. WPA authentication works with other routers, just not the router I have at home. To be clear...

  • WPA with other routers works.
  • WPA with my home router works using Windows.
  • WPA with my home router works with other Ubuntu systems.
  • Only trouble is with Ubuntu's Atheros firmware and this particular router.

Odd, but easy to fix. It's an old router anyway. :)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.