1

I have Ubuntu 16.04 dual-boot installed (w/Windows 7) on a Dell Latitude 6420 Laptop.

Yesterday, after the update, it requested reboot, then would not reboot completely. It got up to the user login, then would freeze after I entered my password. A couple times it also froze at the login, not allowing me to even enter a password.

After some reading, I attempted logging in "safe mode". First I experimented with logging into the first option (ending in "generic"). I could log in and use the machine with no problem. But upon logging in as normal, it continued to freeze.

After doing some more reading, I repeated the process, this time choosing the option ending in "recovery mode".

From there I chose the option, fsck... it ran and provided me with information about missing dependencies on my swap partition.

fsck error screenshot

So now my computer and I are having a really awkward moment of silence. It is holding, exactly as you see in the screenshot, waiting for me to do something, I suppose. And I'm here waiting for it to indicate to me what I'm supposed to do next.

So I have 2 questions:

  1. What do I do next?

  2. How do I go about remedying the missing dependencies? Or is fsck supposed to do this?

Additional Info:

'exit' worked to get me out of this screen, and back to the grub/recovery mode menu

From this menu, choosing root access, then entering 'sudo fsck -f /' at the prompt, produced this response:

Root access

Then I rebooted. Normal boot still didn't work, so I rebooted again into the generic option. I ran the following:

sudo blkid

/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/sda1: LABEL="System Reserved" UUID="2C2A0DEA2A0DB23E" TYPE="ntfs" PARTUUID="f752fb6f-01"
/dev/sda2: LABEL="Windows 7" UUID="5E98156C981543C5" TYPE="ntfs" PARTUUID="f752fb6f-02"
/dev/sda4: LABEL="Swap" UUID="4c570f54-c0d4-44ac-a132-9517c64f0cff" TYPE="swap" PARTUUID="f752fb6f-04"
/dev/sda5: UUID="4320c663-1161-4fe9-b5f8-ac72526376db" TYPE="ext4" PARTUUID="f752fb6f-05"`

cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=4320c663-1161-4fe9-b5f8-ac72526376db /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda4 during installation
UUID=4c570f54-c0d4-44ac-a132-9517c64f0cff none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0`

cat /etc/crypt*

cryptswap1 UUID=ce2b005b-dea2-4808-86eb-71884dfeb5c4 /dev/urandom swap,offset=1024,cipher=aes-xts-plain64

NOTE: Whereas booting into generic worked normal before, I now have no internet. When I open the Network Settings, and try to switch on Wi-fi, it flips itself back off. It does not work on the Windows side either. Windows does boot up normally otherwise.

Then I rebooted with the Boot Disk, ran gparted and snapped this image:

Partition Image

Update:

With every reboot, I keep checking to see if I can log in normally. Before being able to implement the suggestions below, my machine booted normally, in normal mode, but still without wi-fi (I have not yet attempted to wire it into the modem directly)

While booted normally, I checked all of the following:

gparted (corrected)- all partitions that are supposed to be encrypted are. I will add photo here in a few.

sudo blkid (changed) - there is a new line at the bottom containing an UUID for cryptswap1 that wasn't there before:

/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/sda1: LABEL="System Reserved" UUID="2C2A0DEA2A0DB23E" TYPE="ntfs" PARTUUID="f752fb6f-01"
/dev/sda2: LABEL="Windows 7" UUID="5E98156C981543C5" TYPE="ntfs" PARTUUID="f752fb6f-02"
/dev/sda4: LABEL="Swap" UUID="4c570f54-c0d4-44ac-a132-9517c64f0cff" TYPE="swap" PARTUUID="f752fb6f-04"
/dev/sda5: UUID="4320c663-1161-4fe9-b5f8-ac72526376db" TYPE="ext4" PARTUUID="f752fb6f-05"
/dev/mapper/cryptswap1: UUID="e9166797-d813-4430-ab6e-d2f060ca59c5" TYPE="swap"

cat /etc/fstab - the same, no change.

cat /etc/crypt* - the same, no change.

So I could no boot in normally, so my immediate problem was remedied. I rebooted into grub and ran fsck again, and there were still the same dependency errors.

So I entered into the grub root prompt as directed below and made the suggested changes. It did not boot normally. In generic mode I was able to grab a screenshot of gparted. Now the home partition is encrypted, but not swap.

I then realized what direction @heynnema was going and noticed that new UUID in fstab and reworked his instructions using that UUID. Now it boots normal AND all partitions are encrypted as they should be.

However, when I go back into grub and run fsck, the same dependency errors are still there.

I'm not sure if I should count this as solved. I do have full access of my computer (sans wi-fi), and have successfully exited the grub.

Are the dependency errors something I need to worry about? I thought dependencies were parts of update files and such - is the content I was adjusting also considered dependencies?

(The wi-fi issue, I'll put in a different post)

The learning curve is steep...

Update #2 Additional Info:

free -h

              total        used        free      shared  buff/cache   available
Mem:           3.7G        1.5G        712M        216M        1.6G        1.8G
Swap:           14G          0B         14G

swapon -s

Filename                Type        Size    Used    Priority
/dev/sda4                               partition   15625212    0   -1

sudo lshw -C network

[sudo] password for : 
  *-network               
       description: Ethernet interface
       product: 82579LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eno1
       version: 04
       serial: d4:be:d9:24:ae:23
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.13-3 ip=192.168.1.201 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:25 memory:e6e00000-e6e1ffff memory:e6e80000-e6e80fff ioport:5080(size=32)
  *-network
       description: Network controller
       product: BCM4313 802.11bgn Wireless Network Adapter
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=bcma-pci-bridge latency=0
       resources: irq:17 memory:e6d00000-e6d03fff
  *-network DISABLED
       description: Wireless interface
       physical id: 2
       logical name: wlp3s0b1
       serial: c0:18:85:76:83:d1
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=brcmsmac driverversion=4.10.0-27-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11

dkms status returned nothing

rfkill list

0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

fsck after disabling swap

imgur.com/a/bKL64 (it wont let me post any more links) It does not even list any swap information.

Update 3 Info

free -h

              total        used        free      shared  buff/cache   available
Mem:           3.7G        1.9G        649M        322M        1.2G        1.3G
Swap:           14G        3.5M         14G

swapon -s

Filename                Type        Size    Used    Priority
/dev/sda4                               partition   15625212    3604    -1

fsck in grub menu produced same dependency errors.

I notice however, that in the TIME line, parts of the number match the UUID for the old cryptswap1 - but not an exact match. I kept it in case I needed to change it back.

cat crypttab.old

#cryptswap1 UUID=ce2b005b-dea2-4808-86eb-71884dfeb5c4 /dev/urandom swap,offset=1024,cipher=aes-xts-plain64

I looked in the /dev/disk/... that it indicates and found this:

Latitude-E6420:/dev/disk/by-uuid$ ls -al
total 0
drwxr-xr-x 2 root root 120 Jul 27 22:03 .
drwxr-xr-x 6 root root 120 Jul 27 22:03 ..
lrwxrwxrwx 1 root root  10 Jul 27 22:04 2C2A0DEA2A0DB23E -> ../../sda1
lrwxrwxrwx 1 root root  10 Jul 27 22:04 4320c663-1161-4fe9-b5f8-ac72526376db -> ../../sda5
lrwxrwxrwx 1 root root  10 Jul 27 22:04 4c570f54-c0d4-44ac-a132-9517c64f0cff -> ../../sda4
lrwxrwxrwx 1 root root  10 Jul 27 22:04 5E98156C981543C5 -> ../../sda2

It's like it's looking for something that's not there, but all of my partitions seem accounted for.

2
  • fsck is for checking and correcting error on partitions and the reason it didn't work is because apparently Ubuntu was installed with LVM/encryption. It has nothing to do with dependencies, two entirely different beast and both UNRELATED to your issue because: First I experimented with logging into the first option (ending in "generic"). I could log in and use the machine with no problem.
    – user692175
    Jul 25, 2017 at 19:11
  • My swap is in a separate partition and is also encrypted. I'll be including the screenshots here in a few, as suggested below. Thank you for your comment.
    – mbrasseau
    Jul 25, 2017 at 19:29

1 Answer 1

0

Lets rerun fsck, and then gather some data...

To check the file system on your Ubuntu partition...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors

Now we gather some data...

  • type sudo blkid
  • type cat /etc/fstab
  • type cat /etc/crypttab
  • type free -h
  • type swapon -s

Take picture and add them to your question and I'll take a look.

Boot to a Ubuntu Live DVD/USB and start gparted. Take a current-window-only screenshot and add that to your question.

Update #1:

Somebody must have been repartitioning the HDD/SDD, yes? It looks a little strange. And the UUID for the swap partition isn't consistent in blkid and cryptswap1, and fstab looks like it has some erroneous character in it.

Get to the root prompt, as per above, and type:

sudo mount -o rw,remount / # to remount as r/w

In /etc/fstab...

sudo pico /etc/fstab

check that this line...

/dev/mapper/cryptswap1 none swap sw 0 0`

gets changed to...

/dev/mapper/cryptswap1 none swap sw 0 0

Then in /etc/crypttab...

sudo pico /etc/crypttab

Change this line...

cryptswap1 UUID=ce2b005b-dea2-4808-86eb-71884dfeb5c4 /dev/urandom swap,offset=1024,cipher=aes-xts-plain64

To this...

cryptswap1 UUID=4c570f54-c0d4-44ac-a132-9517c64f0cff /dev/urandom swap,offset=1024,cipher=aes-xts-plain64

Then reboot.

Update #2:

Something just doesn't look quite right. Important to answer all questions.

  1. when booting, does it ask for a decryption password?
  2. when you do the fsck (do it my way, not from the menu) does it show pass 1, pass 2, etc and then return you to the # prompt?
  3. does it still show the problems with swap?
  4. when did the wireless network problem start?
  5. are you able to direct wire a working ethernet connection?

Show me:

free -h
swapon -s
sudo lshw -C network
dkms status

Update #3:

You didn't show me the output of the above 4 commands. Edit your question with this output BEFORE performing the rest of this update.

Boot in such a way so you can see the swap error messages. Copy down as much of the displayed UUID's as possible. Compare them to both the old, and the newer sudo blkid commands, looking for a match.

Temporarily we're going to disable swap and swap encryption so that we can see if it has any effect on the wireless problem (I don't think it will).

In terminal...

gksudo gedit /etc/fstab

Edit these lines and comment out the last two lines by placing a # in front of each line. (Remember to uncomment these lines later).

Change this:

# swap was on /dev/sda4 during installation
UUID=4c570f54-c0d4-44ac-a132-9517c64f0cff none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

To this:

# swap was on /dev/sda4 during installation
#UUID=4c570f54-c0d4-44ac-a132-9517c64f0cff none            swap    sw              0       0
#/dev/mapper/cryptswap1 none swap sw 0 0

Then rename this (remember to rename it back later):

sudo mv /etc/crypttab /etc/crypttab.HOLD
reboot

Check the wireless.

1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Thomas Ward
    Jul 30, 2017 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.