When I get to the login screen, I put my password, and I only get a black screen for 2 seconds, then we're back at the login screen. When I log in to the guest account everything works perfectly.

What I've tried; I deleted .Xauthority as per instructions from elsewhere. No luck I removed 2 lines I put in .profile. No change Installed Gnome, but Unity, Unity 2D, various vers of gnome, same thing.

according to other q/a's, this could be caused by lack of disk space. I have 80 gigs free, so I would assume it's not that

if I Ctrl+Alt+F2 at login, I can login in to my account in the "terminal" with no problem. I would really appreciate any help to restore my account, and thank you very much beforehand


2 Answers 2


It works perfectly now. I decided to examine my .profile file again, and I discovered a rogue apostrophe at the end of the last line. I must have grazed the ' button when I input those 2 lines, that I removed later. Delete that and everything is good. Thank you for helping me.

PS. using 11.10

  • If this post solved your problem, please accept it as an answer. May 11, 2012 at 12:03

You have to change owner for these files: .Xauthority and .profile, exist in your /home directory. see bellow for example.

Press alt+ctrl+f2, you'll be prompt on terminal, now log-in same user account in which you facing problem and use these commands:

ls -lha
sudo chown username:username .Xauthority
sudo chown username:username .profile

Where username is that username which you need to login.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.