0

I'm new to Linux and I was trying to set up dual boot on my Lenovo Thinkpad Edge E430 by installing Ubuntu. I already have Windows 10.

For the installation I prepared a bootable DVD with Ubuntu MATE but it didn't boot at first. Then, I entered into the BIOS via windows 10 mode and I set up my boot on legacy mode (my mistake here). After doing that, the DVD was available in the startup menu and I was able to install Ubuntu.

After I installed ubuntu I was not able to get back to Windows 10 because my laptop is still in legacy mode. But the real problem here is that I can't repair this situation because I'm not able to get back to BIOS. I tried several times all the methods on Lenovo to interrupt the startup and enter the BIOS and change my boot mode back to UEFI but nothing worked.

How can I get into it?

  • 4
    Usually ESC immediately after pressing power works. Or this: forums.lenovo.com/t5/ThinkPad-11e-Windows-E-and-Edge/… and, needless to say. it has nothing to do Ubuntu. – user692175 Jul 25 '17 at 5:56
  • Also this: support.lenovo.com/ar/en/solutions/ht500222 – user692175 Jul 25 '17 at 5:58
  • you can try: press "c" in grub to get command line. and see if fwsetup will do it. once in the setup options, you want UEFI on and secure boot off in order to install ubuntu. – ravery Jul 25 '17 at 6:14
  • As a final resort, unplugging the hard disk will usually force the computer into its firmware setup utility. This may cause UEFI boot entries to be lost, though, which could complicate booting after you re-attach the drive, so you should definitely hold this as a last resort option. Also, some modern computers make it difficult to unplug the hard disk, especially if you're not comfortable opening up computers and mucking with their innards. – Rod Smith Jul 25 '17 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.