8

Before anything, this is not (as far as I could search) a duplicate.

I enabled GOA for my Google account and enabled Files, so my account showed up in Nautilus under my computer just fine. To my surprise I also have Thunar file manager and it showed up there too. Great!

Now I was wondering if I could access it using the terminal, or Terminator or whatever terminal emulator I have installed. Following some recommendations I found online, since this is a Gnome Virtual File System (GVFS) I listed the contents of my gvfs location like below:

ls "$XDG_RUNTIME_DIR"/gvfs/google-drive\:host\=gmail.com\,user\=username

And it showed (apparently) my files and folders but in a somewhat decoded format, like below:

ls "$XDG_RUNTIME_DIR"/gvfs/google-drive\:host\=gmail.com\,user\=username
0B2f4njx3e-blablalba    0B2f4njx3e-blablalbe
0B2f4njx3e-blablalbi    0B2f4njx3e-blablalbo

So, I thought the native gvfs tools could, maybe decode that on the fly, so I tried the below which showed a similar output:

$ gvfs-ls google-drive://[email protected]/
0B2f4njx3e-blablalba
0B2f4njx3e-blablalbe
0B2f4njx3e-blablalbi
0B2f4njx3e-blablalbo

Well, has anyone seen that before? And could anyone make it work?

I know there is a FUSE-like driver by some enthusiast that apparently works and I will totally try it if this native one doesn't work, but I wanted to be able to be sure there is no way to make it work with native software.

4
  • 2
    This question is still valid for Ubuntu 20.04 too...
    – FedKad
    Jun 22, 2020 at 17:32
  • 1
    Since I asked that question I moved to Arch and started using [gdrive] (github.com/gdrive-org/gdrive) command line tool. It has worked although I found some issues, which I believe are more on my side. Give it a try. Jun 23, 2020 at 14:53
  • The file names in the output of the gvfs-ls command are encoded because GVFS uses a virtual file system to access the files in your Google Drive. When you access your Google Drive through the command line using GVFS, the file names are translated into an internal representation that is used by GVFS to identify the files. This internal representation is not intended to be human-readable, and so the file names are not displayed in their actual form.
    – mhadidg
    Dec 21, 2022 at 20:09
  • See this: askubuntu.com/a/1332056/855322
    – FedKad
    Mar 20, 2023 at 9:09

0

You must log in to answer this question.

Browse other questions tagged .