1

I recently bought a Dell XPS13 9360 with Ubuntu (with Unity) 16.04. I also bought a DA100 USB3 (ethernet, USB and video) adapter.

While running 16.04 the adapter worked fine. When I upgraded to 17.04 (probably not "officially supported" but...) the adapter stopped working.

Dell have released an update to driver for the DA100, but unhelpfully they are only in "Windows OS" format.

I've tried using the updated drivers from Displaylink, but they have not worked.

I've taken a output of usb-devices before, and after installing the drivers. I've also dumped the driver install outputs.

They're all available in the logfiles in this Dropbox share.

  1. usb-devices-probe-before-install-drivers.log
  2. install-da100-drivers.log
  3. usb-devices-probe-after-install-drivers.log

Has anyone gotten the Dell DA100 adapter working on a XPS 13 9360 running Ubuntu 17.04 Gnome 3?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.